Blender UI paper cuts

I think I remember it’s a technical limitation. As far as I know, the concept of island only exists in the UV editor, and that makes it unfriendly to the 3DView. Obviously, it should be added.

1 Like

Can you please free up some free space for the Pause Previee button? This is terrible, insanely annoying.

Why this panel is not a modifier or a particle type? it’s really hard to work with it



In the dope sheet, pressing Shift-D on the keyboard with keyframes selected duplicates them, but in the menus, there’s only a “duplicate marker” option in the Marker menu that corresponds to Shift-D, and worse, when selected it duplicates non-existing markers (ie actually creates them, even if only keyframes are selected).

1 Like

Because, as it stands right now, modifiers cannot produce instances. With modifiers, it generates a single mesh - see the Array modifier for example.

1 Like

I dont see problem in that, but for that reasons I told particles also. A new type of particle “Emission, Hair, Instance”.

1 Like

hard to read… just icons is very bad when u want to check stuff a icon + text is way better

This is not at all serious, and it is probably a work of perfectionism to save some superfluous computing cycles.

I noticed that every time I press the property buttons, the rendering starts again, and I think it’s completely superfluous, I also think it could become a bit annoying in the heavier scenes.
It happens only with EEVEE, not with Cycles and only when I press the properties buttons, it doesn’t happen with other elements of the ui.


This doesn’t happen to me with latest master, nor with 2.81… but it does refresh when hovering on the navigation buttons and generally every time there’s a redraw in the 3d view (changing the cursor location also triggers it).

Found this in d.b.o Clément seems to aware of this kind of problems.

1 Like

have you tried with soft shadow enabled?
I noticed that the refresh concerns only some features, like the soft shadow, global illumination and other things like that … especially the phase that must “do the final sampling”

Yes I did, I think the refresh happens anyway, but it’s way easier to notice with those settings since they depend a lot on the samples count.

Maybe it’s an OS dependent thing (I’m using linux) in that case it would be another layer of complexity, and might be worth it to submit it as a bug.

in fact it is on windows, but it is strange that there are this kind of differences

I’m not sure it can be defined as a bug, so I preferred to report it as a papercut

I tried it on windows10. also not happening here with 2.82 ( softshadows are turned on and i can force it to trigger redraws, but not how you did it)

Edit: Just updated to latest build. Still not happening, just if the cursor is the resize symbol (hovering over area between the tabicons and the tabcontent and clicking)

The following shortcut toggles between Edit Mode and the Last used mode for Mesh objects but behaves differently with grease pencil objects.
I want to toggle between Draw mode and Edit mode but what it does while I am on Draw mode is: on first press it goes to Edit mode but pressing again takes me to Object mode instead of going back to Draw mode. Afterwards it simply toggles between Object mode and Edit mode.

This really gets in the way of smooth grease pencil workflow. Please fix this.

1 Like

Could be possible show the number of instances inside the mesh icon in the ourliner?


At this point I don’t know what happens, maybe something limited to my hardware? :thinking:

Hmm. Not really sure if this can be a hardware thing. The redraw is somehow triggered by the UI. Just tried it once more and I found a way to trigger it. Don’t know if that has been the your case. But if the rendering in the viewport hasn’t finished, then a click on another tab will restart the 3dviewport render. So what I did was to set the number of samples to unlimited ( =0) and started to switch tabs. Was that also your setup?

Could you try the last build?

Edit: I can confirm that happens in my pc also.

Ok, can confirm this as well doing so.

@Debuk @a.monti

I forgot … you have to set the light radius greater than zero otherwise the softshadow will not fliker and you don’t notice the refresh.
the samples are the default ones 16