Blender 2.8 Wireframes Discussion


#170

Wouldn’t it be too crowded?
Those menus could be very messy very quickly.


#171

Changing guid color doesnt affect borders. Actually I thought that borders must be rulling by the Outline option in the Shading popover, but nothing changing when empty (image) is behind. Interesting situation – I changed orthographic view to perspective - and where model intersects with null objects - dotted wireframe without borders, where not - outline borders exists.


Screenshot has not been edited


#172

If it will be helpfull, here is a source file: https://yadi.sk/d/bk1_Vs_0a93Yyw

If image doesn’t embedded to a blend file, here is a drawing:


#173

Problem that is see: empty images are drawn on top of wires regardles of depth settings


#174

You’re right, that’s a problem. When you modelling by the drawing, you not able to see the border of neighbour objects… It’ll be great if this issue will be fixed in next releases.


#175

The problem could be linked with the problem that ire is draw behind everything, for example the grid.


#176

@Zuorion I already said it in October 12 2018, but we didn’t get any response from any developer.

Blender 2.8 Wireframes Discussion


#177

it has been reported as a bug.
https://developer.blender.org/T58985


#178

When you have a very dense grometry the grid in wireframe mode and xray 0, the grid always seems to be above your object when this is not the case.


#179

Is anyone else encountering an issue where edges extend beyond vertices? The issue is not very pronounced with thin lines, but when thick lines are turned on the error becomes quite obvious. The issue is more pronounced with vertices that are close to one another.

I’m using the latest 2.8 build as of 1/4/19 on OS X.


#180

The new wires in edit mode are horrible. They can become totally unusable. Please bring back the old wireframe!

This one is SOLID MODE with X-RAY OFF
image

This one is SOLID MODE with X-RAY ON
image


#181

I’d just like to add my voice to the number of people here who are expressing some frustration with the new wireframe rendering of Blender 2.8

There are so many things I love about 2.8 but honestly the most critical part of any 3D modelling application is 3D modelling, and a good wireframe mode is essential for 3D modelling. I have tweaked 2.8 as much as possible, but it’s only barely usable with the new wireframe rendering style, I’m struggling to see the wireframes in a lot of cases against the grid (which appears to be in the foreground and not the background) and even after all the tweaking I’ve done, I still can’t seem to get the wireframe anymore than 50% opaque. which is just incredibly frustrating. The ‘X-Ray’ mode, although it offers a slider from 0 to 1 it really feels like it’s a slider from 0.5 to 1.0.

I just want some solid black lines. : c


#182

Here’s an example of what I mean. The left is Blender 2.79, the right is Blender 2.80. The difference is huge. The version on the right is the absolute best I can do after spending hours tweaking the theme and view settings and searching for options to adjust the wireframe, the default settings are even worse.


#183

Good example, is near to impossible to read a complex shape with actual wireframe…


#184

I may be wrong but I don’t think a Developer posted a single time in this thread.
So unfortunately we can’t be sure there’s one reading and considering our feedback.


#185

@Hypersomniac What are your thoughts on this? Thanks in advance.


#186

Here are a few screenshots of how wireframes are showing up on my computer. Not sure if any of you’ve had this issue. If you have, and have any fixes for it, please let me know. The only way I’ve been able to sort of “fix it” is by increasing the clipping start setting. This, however, isn’t really an option because the model is quite small, so the clipping gets in the way.

Edit mode in vertex mode, but it happens in edge and face mode as well


#187

Right now no, I don’t think there’s a direct solution – the problem is caused because the shader manually applies a small offset so that vertices are shaded above the surface instead of clipping through it (though it’s still not perfect even after that; it used to be worse: Blender 2.8 viewport quality in edit mode - feedback)

One workaround you might be able to try is to model on a proxy object. Just as many VFx studios already model at 1/10th scale for their scenes / large props, in your case you need to model at 10x scale. Alt-D duplicate your mesh. Scale that duplicate up and model on that one… then ensure that works acceptably on your original object. I say might and acceptably because you wont be able to apply-scale on that duplicate which means certain mesh ops may skew (a uniform scale of 10,10,10 shouldn’t have many issues though). If that fails, you’ll have to model the base object at some higher scale in the first place: i.e. model at a larger scale and then alt-d duplicate / scale-down for your final scene placement; this way you can continue to make changes to the mesh at a base 1,1,1 scale and have it reflected at its true size later.


#188

I was afraid there wasn’t going to be one. I appreciate your suggestion, though. I will give it a shot, hopefully it’ll work. Let’s just hope it gets sorted out, because it’s quite annoying.

I wish there was an option in the preferences to select between 2.7x and 2.8 wireframes.


#189

Yeah I posted this months ago, when my face dots were appearing on top of the front faces… I thought they had solved this (I didn’t open my file to check) but apparently not.