GSoC 2019: Core Support of Virtual Reality Headsets through OpenXR

Oculus update 1.40 (currently on the public test channel) restores openXR support and blender works again!

3 Likes

A meeting sounds good! (Though I’d prefer Skype or Hangouts over VR :wink: )
Let me know when.

For the records: Siggraph 2019 OpenXR Birds of Feathers presentation: https://www.youtube.com/watch?v=cnNvR-Tp5xg

1 Like

I just saw this in action at work using a Vive - it is in a very cool state already for previewing scenes in VR!

I haven’t seen an openXR run-time from valve just yet, any insights you can share about the availability of it? (or where to get it?)

I just chatted to the lad who had downloaded the VR demo that I tried out at work, it was actually this https://www.marui-plugin.com/blender-xr/ and not the GSoC project.

Ah bummer, i thought we were onto something here :slight_smile:

Blender now presents on the Vive with Monado. Is there suppose to be head tracking? Also is it possible to change the viewport shading mode?

Awesome! The fact that it just did nothing for you worried me a bit and didn’t make sense. I assume this got fixed on Monado’s side.
There is no head tracking support for most HMDs in Monado - or rather the OpenHMD drivers it relies on.
Neither do we support changing any settings for the VR view yet. We prefered keeping it very simple for now and figure out how to integrate such things nicely into the ‘big picture’. See T689940.
Anyway, great to know Blender and Monado finally work together!

2 Likes

My bad, both the tracking and display is now working with Monado. The usb ports on my machine died, Monado was just happy to use the HMD as a display despite that…

Quick experiment using my WMR acer headset using a AMD radeon Pro polaris card gives me either a black screen ( not off black more like black screen waiting) or more often a pink screen. Tried various models and same result each time. Not sure if the issues with myself or something in the setup.

I was able to make it work with an Oculus Rift, but when I take off the HMD and put it on again, the display inside the Headset shows an hourglass and black screen. I have to restart both blender and the oculus app.
When it is working, it looks as if the view angle is a bit off: the horizon - which I think should be the infinity of the x-y plane - is somewhere else; the image is tilted downwards.

And: is there a way to use a Vive Pro on Windows?

By default it takes the camera rotation for the headset wich is on an angle for the default cube scene. If you set it back to 0 all is normal

It doesn’t work on HTC Vive in Windows, right?

afaik valve has not released an OpenXR run-time for vive, so currently it won’t work

Hey got a question - Will we be able to animate using motion controllers and a VR headset?

Things such as Posing and Animating would be made so much easier if this was supported. :slight_smile:

The point of the GSoC project was to bring XR support into blender. Everything beyond that (input related stuff, everything UI-related and overall vision of XR in blender ) you can read about here https://developer.blender.org/T68998

1 Like

I just downloaded the custom build but can’t find the addon to enable. I’ve tried enabling ‘Testing’, etc.
thanks

I’ve noticed that too a few days ago, it’s probably not using the correct Add-ons branch. I do rely on @LazyDodo to fix this though, since he is awesome enough to create these builds for me.

Meanwhile you can launch the session directly through the Blender Python Console:

bpy.ops.wm.xr_session_toggle()

Sorry about that! Fixed the issue, the GA build should be OK again now!

4 Likes