Blender 2.8 Wireframes Discussion


This is probably a bug


Wire frame has vastly improved in the last months, but I still feel selection should only work with what you can see. For instance, If you click in the middle of the default cube, where there are no wires visible, this should be like clicking in empty space. This is not the case right now and if you click a visible edge of a back ground object through another object, you will in fact select the background object, but click again in the same place, and the foreground object is selected. I have a feeling I know why this is happening right now, but I think a hack should be made so that clicking a face (which should be invisible in wireframe mode) should not select the object.

I don’t want to complain too much about this, because the software is pretty well usable right now and overall, I’m very happy with 2.80.


This is one of my major gripes with the new wireframe… I’m used to clicking on wires behind other objects and selecting first the object which own said wire/edge, not the object in front first.


For me, its a bug :smiley:


I love everything about 2.8 so far, except the wireframe mode. Its harder to read than 2.79.

Back in 2.79 to view wireframe I only needed to press 1 button, which was “Wireframe”. Now I have to press “Wireframe” + “Show whole scene transparent”.

When “Show whole scene transparent” is enabled, verts are almost invible in edit mode. See left side of attached image. HOWEVER, when I try to pan or rotate an object, verts become clear and visible ( like on right side of image but with xray on (because “Show whole scene transparent” is enabled - sorry I cant make screenshot while panning or rotating, but it looks). Is it just me or others experience this too?

Is it possible to keep verts clear in edit mode while no buttons are touched?


You can increase the vertex size in Theme settings 3D View if you want. This particular problem I don’t think is bad, the dithering is the real problem here.

I read @Hypersomniac stating that wireframe mode is actually a very complex shader even though it looks and sounds simple. The translucency is done with dithering because you can’t alpha-blend easily with so many different overlays already blended together.

When it comes to dithering, possibly the color of the wireframe could change to blend between viewport background color and actual wireframe / seethru-face color.

So the deeper something is in the model the more the color of it’s wireframe gets close to viewport background color. This could help with the dithering problem without need for alpha-blend.

I don’t know how complex this is to do from programmer’s perspective as opposed to dithering. I understand that with dithering many many transparent depths are possible but it’s impossible to read even after the first depth anyway.

Even caring about just single depth would be better than having everything dithered.

So if background is 0.250 dark grey and wireframe is 0.000 black the wireframe behind is 0.125 dark dark grey and faces blend with the same approach - a kind of very simple transparency.


I feel the same. If i see the wire, and it is isolated without any other wire on top of it, i should be able to select the object whose edge i am clicking on, not the object that may be sitting “in front” of the one i wish to select in relationship to the view.


We also need Wireframe option in the Workbench Render Engine panel.


Hi. I use Blender for fixing models for 3d printing because it allows me to fix even the smallest errors (they must be closed geometry without non-manifold problems). So for these, I’m constantly switching between solid and wireframe mode while using the “Select Non Manifold” and the “View Selected (shortcut “.”)” options.

In this first built I found that it helps a lot to have this kind of 3D/deep feeling wireframe most of the time but it is also a lot of trouble when trying to see isolated selected vertices in high density models.

Here at the left is blender 2.79b, where you can easily see that there are 4 vertices selected; while at the right is 2.8 with also 4 vertices selected.

It’s almost impossible to find the selected vertices that are behind or within other high density meshes (forcing me to blindly keep drawing deselection boxes until I have left just a few vertices selected within a small area, and then been able to zoom in (pressing “.”) and actually seen some of the non-manifold vertices selected with “Select Non Manifold”) then repeating this blindly deselection process through all the model.

Is there a way the old solid wireframe view could be enabled as a wireframe mode? maybe an option where the selected vertex could be rendered over the 3D wireframe, or something like toggling off X-ray looks now but, instead of only showing the visible geometry, rendering all the hidden geometry as well.


While I must admit it is not convenient, it’s not simple to fix.

So as a workaround I suggest to

  • select non-manifold
  • increase selection (ctrl + Numpad ‘+’)
  • invert selection
  • hide selected
  • select non-manifold again

Now you have the problematic areas to work on with a bit of context.


The facedot is draw outside the faces in an object with subdivision.


isn’t this food for papercut?


mmm, maybe, but I don’t think so. Papercut is about UI and this thread is about wireframe and @Hypersomniac is here, I don’t think that he enter a lot in the other thread. But could be.


Other feedback about wireframe, actually the grid is draw over the wireframe. For example, if we have a model over the grid we see the grid and it appear that the model is underground.


Yes, I think for most of the cases that should work. Thank you!


Can’t we have the new 2.8 wireframe for object mode and the old 2.79 wireframe for edit mode? The new one is pretty to look at, but it’s unusable when editing more or less dense meshes because the lines are too thick. Also, when using background images/empties, the dithering blends in with the background and sometimes the mesh gets lost entirely.


The color of the background for the current default theme, dificult to see the wireframe:

here clarifying a little the background color at least you can distinguish a little better the wireframe:

another option is to put the wire edit in pure black, normal wire a little clearer, and the background color up slightly lighter:

it’s a little hard to see, but it’s still better than the default theme colors.

defaultfixzebus.xml (40.7 KB)


The dithering is basically the problem Adam… Iam agree with you… The dithering is the greatest headache when you are working during hours modeling… I lose the visual contact with my wireframe… I hope that this situation change. Kind regards guy.


This two images speak alone. With lines in old rs Losting edges in the new release. I can´t work now as easy as after.


Wireframes in 2.80 is a total pain and a reason I still use 2.79
For some reason they are 2px thick in Edge Selection mode (And it’s even harder to look at in combined Vertex+Edge mode).
I described it in details in a topic nearby.
I don’t understand why change what was already good in 2.7? AntiAliasing? Old wires was ok with AA in 2.7 - no reason to make them twice as thick.
I hope there will be option in preferences to controls that, like we could control vertex size now.