Blender 2.8 Wireframes Discussion


#85

I think in this case you should have activated the “In Front” (old object x-ray), in the object Viewport Display options, so that the sphere is drawn completely in front of the empty plane. Or those screenshots are with that option active?


#86

The previous images had the default xray when you press z and choose wireframe, now I have tested with xray


I hope it can be fixed. Maybe @Hypersomniac knows something about it.


#87

I’m testing on 2.7 and the problem seems to be empty image itself.

This would be a good reason to return to the traditional background image instead of using these empty images. With the image background from a camera in 2.8, you can see that if it works better than with the empty image


Background Images Feedback
#88

I might be missing something very obvious but what’s the issue exactly?
Your mesh seems to be intersecting with the image empty, which shouldn’t. So how about move the image empty back a bit so it’s not intersectng? That way it should behave like a background image… :thinking:


#89

The sphere with wireframe is a gray blur stain, does not distinguish the wireframe, I think it’s obvious that it’s wrong, even if it’s in between the empty image, it should look good. With the traditional background image it works perfectly, as I demonstrate when using the image background, that is currently only available from a camera.


#90

Still not quite sure what you mean… Things seems to be working… :thinking:


#91

Get out of edit mode and tell me if it looks like professional software what you see on screen


#92

It happens whenever an object is behind something with transparency. I ran into the same issue working on a cosmonaut. I had to hide the glass shield on the front of the helmet to adjust verts on the guys face. I started out with a refractive surface for the glass and tried making it just transparent - neither one worked. This was on a 980 gtx. I haven’t tried it on my p4000 at work but I think the issue is one of the shaders being used and not a hardware issue.

Is your sphere penetrating the image plane?


#93

Oh, I thought you were talking about the edit mode, So yeah, in object mode it looks a little weird.

No.


#94

@DanPool “Is your sphere penetrating the image plane?”

Yes, it’s intersecting.

I thought in this image it was clear:


#95

Yeah I could tell with yours. I couldn’t with RedWaxPolice’s.


#96

Why would you leave it intersecting like this?


#97

You modeled in half of a model and with the modifier mirror you dont need modeling the other half of the model, is a common practice in modeling


#98

I know the modeling practice. But with image planes is also a commom practice to put them behind the mesh. So it behaves like a normal background image.


#99

I know I would do this in 2.7x and 3ds Max because you could hide some of the faces behind your images while still being able to select verts/edges/faces on back facing geometry. All of this while being able to adjust what’s hidden very quickly. Otherwise you’d have to hide faces, unhide all of the faces again, make a new selection and hide it. With this method, you can slide the plane to interactively “slice” off the back.


#100

The easiest and most practical solution would be to return the background image we had in 2.7 so we would all be happy and not have to waste a lot of time fixing a wireframe. It is clear that with the background image these problems disappear directly.


#101

With enable and disable the modifier mirror I think it would be sufficient, about what you’re saying


#102

The “In Front” (old object x-ray) option that I mentioned is not the new X-ray slider that you showed.
Is this option:
2.79:
image
2.8:
image

Anyway, this doesn’t solve it.
I’m writting another in-depth answer. It appears to be a render problem with 2.8


Background Images Feedback
#103

@zebus3d I tested the issues both in 2.79 and 2.8. You are correct, the empty image is problematic on both versions. In wireframe mode in 2.79, whatever object selected is rendered on top of the other. If you select the dinosaur empty-image, it draws on top of the cube. If you select the Cube, it draws completely on top of the empty, ignoring intersections.
The best way to do it on 2.79 in this case would be to use a regular image-mapped object (instead of empty), or turn off the visibility of the mirror modifier.

Empty Image on 2.79:
-Dinossaur empty-plane selected:

-Cube selected:


As you can see, Mirror modifier is ON.
(Maximum Draw Type is Textured, and X-ray is off, but changing these two options here does nothing.)

But with the Cube on Edit mode, it’s exactly as you would expect it.

Here’s with the Edit Modifier in Edit Mode option active (called Adjust Cage to Modifier)


Too clutered IMO… (This option will be important comparing to 2.8).

-Cube selected, but mirror modifier off:


Much better, but not ideal, because we can’t see the other side of the cube.
And mirror modifier off on edit mode:

.

Plane Object image-mapped on 2.79:
Object mode:


-Wireframe mode;

Useless because the Dinossaur image doesn’t appear.

-Textured mode + Textured Draw Type


We can now see the Dinossaur, but we can’t see the transparency on the cube.
-The same above, but X-ray and Edit Modifier in Edit Mode active :

Useless again.

-Solution: Textured Mode + Maximum Draw Type set to Wire on the Cube:
image
As you can see, the intersected part doesn’t render behind the dinossaur, both on object and edit modes:
image
image
But if we turn the X-ray display option on, we can see the mirror wires FAINTLY behind the dinosaur, on edit mode:


(on object mode it appears equal to the second image on this post).

If we turn on the Edit Modifier in Edit Mode, here’s what happens:
X-ray off (mesh invisible behind dinossaur):
image
X-ray on (entire mesh visible):


.
.
NOW ON 2.8:
Empty Image on 2.8:
-Solid mode:

Notice that the Mirror modifier is On.
The Edit Modifier in Edit Mode is OFF.
In Front (old x-ray) option is OFF
Maximum Draw Type is Textured.

The next set of result are the same on both Object and Edit Modes:
-Wireframe mode, and new X-Ray slider off:
image
-Wireframe mode, and new X-Ray slider On, but set to 0:
image
-Wireframe mode, and new X-Ray slider On, but set to 0.5 (default):
image
-Wireframe mode, and new X-Ray slider On, but set to 1:


Even with X-ray set all the way up to 1, the wires behind the dinossaur still doesn’t appear.
Also, using the Empty-Image, changing the In Front and Edit Modifier in Edit Mode changes nothing.

Plane Object image-mapped on 2.8:
This is the node material of the Dinossaur Plane object in case you are curious:

-Wireframe mode:


Useless because we can’t see the dinossaur image.

-Solid mode:
image
Useless again.

-LookDev mode:


Good, now the transparency of the textured object appears, so this is our starting point.
On edit mode (X-ray Slider OFF, Display as Textured):

Turning on the X-ray Slider to 0 (notice we are not editing the modifier in edit mode):


We can see the back wires, but not of the mirrored portion

X-ray slider to 1:


Absolutely nothing changed.

Disabling the X-ray and activating the Edit Modifier in Edit Mode option:


We see the partially the wires of the mirror portion, but not the face shading.

And enabling X-ray with active Edit Modifier in Edit Mode option:


We can now see the wires of the mirror portion completely, but not the face shading.
Changing the X-ray slider here, again changes absolutely nothing.

PS: On LookDev mode, activating the In Front option changes absolutely nothing, both on object and edit modes (and also does nothing with the X-ray slider or Edit Modifier in Edit Mode option on or off).


In the image above, it should render the mirror side of the cube on top of the dinossaur plane, but it doesn’t.

-Changing the Display As option to Wire, instead of Textured:
Object mode:


In the case above, activating the X-ray slider or the In Front option changes absolutely nothing.
Edit mode:

On edit mode we see only the active portion of the object, unless we activate the Edit Modifier in Edit Mode:

Now we see the full sphere, obviously.

What if we activate the X-ray now?


Changing the X-ray intensity to 1 changes nothing:
image
X-ray on, but disabling the Edit Modifier in Edit Mode:
image

So yeah, those are all the possible options on 2.79 and 2.9.

In my opinion these are the setups that I find most pleasing:
2.79: Empty Image/Wireframe mode/Maximum Draw Type=Textured/X-ray=OFF/Edit modifier=OFF
2.79: Plane Object/Textured mode/Maximum Draw Type=Wire/X-ray=ON/Edit modifier=Any
2.8: Plane Object/LookDev/Display As=Textured/X-ray Slider=ON/In Front=Useless/Edit modifier=ON

The main conclusions are:
-Empty image with X-ray slider ON on 2.8 is useless because it doesn’t show the mirrored portion behind the empty, therefore the only viable option is Textured Plane Object instead of Empty Image right now.
-Textured Plane Object forces us to use LookDev
-On LookDev, the In Front option is useless, it changes nothing whatsoever.
-On LookDev, if an Object that is set to Textured/Solid display modes and it intersects another transparent one, on Edit Mode we cannot see the wire on the mirror portion inside the intersecting area, even with X-Ray Slider or In Front options Active (X-Ray slider does nothing):
image
-They could make the Empty-Image as Background Images system works if they made it appear like on 2.79, where we can see the object wire of the mirrored portion even without activating X-ray. This would be ideald because it work on Wireframe mode (instead of LookDev+PlaneImage).


Also it’s strange how 2.79 semi-transparent face shading was so smooth, while 2.8 face shading is dither nightmare.
Therefore the new system is not the apocalypse @zebus3d, it only has to be adjusted and tweaked.

The end.

These are the blend files if you want to mess with them:
2.79: http://pasteall.org/blend/index.php?id=50499
2.80:http://pasteall.org/blend/index.php?id=50500


#104

I see that with plane geometry in lookdev you have managed to do what should be with the empty in 2.8.

Is a good solution, but I think they should fix the (empty image or wireframe) so that it is not so tedious to configure this setup.

@Evandro_Costa Thank you for the great analysis of the situation you have realized, very good work.