Ctrl + Tab for Mesh Select Mode

So after overreacting on Twitter and creating a mini shit storm, I got the reason why the change and it kinda makes sense. So here it is…


Thank you for your effort :slight_smile:

Lets just hope, it won’t be too slow for low poly meshes

Still, I have bigger issue with CTRL + TAB to select interactive mode. It is confusing (especially for begginers) to have TAB for Edit mode/Object mode and then use CTRL + TAB for other interactive modes

1 Like

Yeah, thats the one that make less sense but they refuse to set back to normal.

Well I guess I will be the dissenter here…
I liked Tab to switch back and forth from Object>Edit mode and Ctrl+Tab to switch to other modes.
But that is because I usually don’t change nearly as frequently to any other mode as I do changing from Object to Edit… so I do indeed prefer the most responsive Tab (the reason for the change was sluggishness due to Pie Menu integrated to the same key) and don’t care too much about using a modifier key to change to another mode, since it’s not so frequent.
And I’ll take a wild guess here and assume mesh modelling (which requires object/edit modes much more than any other mode) is indeed the most used functionality of blender…second place would be pose/object mode changes which is the case for animators/riggers. Even sculptors or texture painters don’t switch that frequently and that’s why complaints about Tab exclusivity for Object>Edit toggle were very rare until now, if even there were any. After all the pie addon has been there for anyone who prefers it.


I’m glad I found this here. I found this to be my biggest problem with the new key bindings. I don’t mind hotkeys changing, but making 1 hotkey turn into 3 hotkeys is a big problem for my workflow and the workflow of my co-workers.
If it has to be changed can we still have a hot key that allows us to switch between the selection types with one button as well? I switch between those far more often than I switch between texture paint, weight paint, sculpt, etc…
I think a solution for this might be to have a left/right-click menu to switch between them, and use alt+left/right-click to move the 3D cursor.

1 Like

I agree, there definitely is a loose hierarchy of key priorities. Changing selection types is fundamental. Object mode to edit mode is fundamental. Very immediate in 2.79. But 2.8 is so impressive overall, it definitely feels like nitpicking to go on about this. Important though.

I disagree that it’s nitpicking. Just because the new blender is becoming very impressive doesn’t mean that it should sacrifice a quick workflow. You said yourself that changing the selection types is fundamental. It’s important for us to discuss issues we have with changes so that the devs can make a proper decision based on the community feedback. I’m very happy with Blender 2.8 overall, this is just a change that I really dislike and feel it is important to discuss.


Well this change sucks for me, because I have a tenkeyless keyboard and I use the Emulate Numpad feature, which when turned on overwrites the new 1 2 3 shortcuts. Having Ctrl+Tab available was awesome, now I’ll have to find a new way to do this, because I can promise you I won’t be clicking the Vertex/Edge/Face icons (I have poor mouse accuracy). If anyone has any suggestions on how to bypass this behavior on a tenkeyless please reply. Thanks.


personally i think the whole modes system needs a revamp ,like selection and deselection should be done with the mouse buttons and switching between modes should be seamless for example the vert/edge/face icons should be displayed all the time and clicking one of them will make you enter edit mode and if you click it a second time it takes you back to object mode and it will even make the text jumping less obvious.
all this will free tab which can be then used for the pie menu.

Yeah, that’s a very important point. I’m sure there is a lot of laptop users who have to use Emulate Numpad.

so that’s it? we’re stuck with this behavior? :frowning:

1 Like

I just had a quick look to see if it’s being discussed anywhere else. Couldn’t find anything.

So yes, I think we are stuck with it.

Such a shame for laptop users with no numpad.

Is it not possible to just change the shortcuts? I find Ctrl+TAB to be blazing fast compared to 1 2 3…

also 1 2 3 I use for front/top/side view and that is golden btw.




Amazing. So thankful you took the time to do this. Much appreciated by all who miss it in 2.8 for sure.

1 Like

I just tried to add the mesh select modes to quick favourites. Not possible.

I can turn on emulate number pad, but I can’t reassign ctrl + tab for mesh select mode when I have emulate number pad on. (not without using Zebus3d’s addon)

I don’t understand why we have this behaviour with such a vital part of the workflow in modelling?

Especially when a large number of the new creators laptops at CES seem to have no number pad.


Well, we’ve got an issue with all those pie menus.
They seems to be hardcoded

I share my personal experience:

recently I’m on a short keyboard, so I use emulate-numpad, so to work more comfortable I got the custom shortcuts:
1, 2, 3 for the ortho views, and alt + 1, 2, 3 for switches between vertices, segments and faces …

and surprisingly I am discovering that my workflow has increased and is pleasantly more comfortable.

1 Like

Your setup doesnot include slot switching, so it seems it does not fit multirefrence modeling workflows.
Yes, it can be handy, but for a simple modeling.

i added the keybinding back to switch selection modes, took me several hours to figure this out…

here is the section where it needs to be added (3D View>Mesh>Mesh(Global)

and the configuration for the keybinding
empty field: wm.call_menu
Name: VIEW3D_MT_edit_mesh_select_mode