Accidentally hiding everything but 1 collection by pressing number keys is very annoying

Since the “1” key is pretty close to “TAB”, i accidentally press it and hide everything but the first collection.
This feature which assigns the first 9 collections to the number keys is pretty annoying and I find it quite useless since it only allows for 9 collections to be managed this way. I’m kindly asking for the feature removal to improve usability and speed.

6 Likes

Agreed, I do that quite often and it’s rather annoying.

2 Likes

You can disable these hotkeys in keymap preferences:

And scroll down:

These hotkeys are here from old layer system before 2.80 collection system. I kinda like them when modelling small projects, but they quickly lose efficiency if you use more than few collections. Plus like you said it’s easy to press them by accident since 1 2 3 keys are used for selection modes in edit mode. Before 2.80 number keys were exclusively used by layers and for edit mode selection we had to use Ctrl+Tab shortcut (just providing some context).

I agree what these days it’s just atavism what does more harm than good.

5 Likes

Thank you very much for a nice solution to the problem, but yeah, I hope it’ll get right by default.

Oh, I do that all the time. Good idea to disable them.

First thing I do when I open blender for the first time is to disable those hotkeys! I was so pissed of each time!

Could a moderator please merge this topic into this one, since it’s the same issue:

2 Likes