workflow, UI weird ?

Firstly, I’ve seen some changes in the Header it feels me so weird. It’s not smooth in workflow in some way:


When you’re working with vertex paint you can’t work as easy as before. This is another example from some older version (early March) clicking on right button mouse:


This is now: (? no color either, no shortcut)


Another thing I don’t know it will be fixed or included, when you’re working on solid/workbench from the viewport and you’re changing some parameters to render in workbench it has not response into blender options :frowning: I must work twice on it, it has no sense, right? I don’t know if it’s a bug or not, I told it to Pablo Vázquez some week ago and he think it could be.


I hope those features are going to fix in some step in your development. It seems too obvious to me. The workbench engine seems incomplete in that way.

Thanks for you attention.


The paint context menus now include the color and blending too:

Your issue with the Workbench is not a bug, it’s a user error. If you want to see the rendered result, switch to Rendered view.

1 Like

How do you open the paint context menu? Whatever, it was easier to have it into header.
I think solid and rendered in Workbench engine should be the same and changing the properties from the viewport translate to render, now it has no sense.

In the Texture Paint workspace, the tool properties are still visible by default:

You can enable them in any workspace by right-clicking on the header and enabling it:

1 Like

That’s incorrect. Rendered view shows you the result to be identical when you render. Solid view can differ in each viewport and is something different.

yes, I know it but maybe I can’t explain myself correctly. I think the changes from the viewport, at least in workbench, could translate them to the render options. I mean, I’m testing some models for some quick renders in that “solid” style and after tricking it in the viewport I must re-do it into the render options.

Not default in my case… I don’t know why? It was by default on older builds

If you want to render out the viewport, use View -> Viewport Render Image or Animation.


It’s on by default for the Sculpting and Texture Paint workspaces

1 Like

I got it! I didn’t know that option from the viewport. Thanks.
But I don’t know if it’s due my system, the viewport render has more quality than the render itself, from the camera’s render (in workbench engine) which is more pixelated and noisy.

and from viewport

have you try antialiasing options and cavity samples?

1 Like

Set the sampling quality here:

1 Like

yes! I set the same samplers in both … :frowning: