Workbench specular... Hardcoded? Why?

If you enable specular on workbenck, you’ll find that speculars doesn’t really relate to te current studio HDRI.
Maybe thats because there is no way of calculating phong speculars out of an enviroment HDRI image, if that’s the case, why not to cotrol it with the Solid shading settings on user preferences or something similar?

We need options for the specular, right now it’s not usable, we cannot change the intensity nor the color and hardness.

Also, if the object has a material and we are set to material, the specular doesn’t take the material in account.

We also need to be able to add opacity to meshes and not only on the entire scene.