Wireframe-Mode for Bones (2.8)?


why isnt there just a normal wireframe mode for bones?! (or is there?)

i mean just like in this picture, but a litte bit different^^ (this is the Transparent mode / Overlays).

my problem with this transparent mode:
if u want to parent (as an example) the biggest bone to the smallest one, than u would shift select the big one and than the small one -> ctrl+p.
but with transparent mode u just select the big one over and over again. which logically makes sense, bcs its the biggest one and the small ones are inside him.
with luck u are able to select the bone in the midde with shift+click, but if u need the smallest one, its kinda impossible.
sure u could work around by hiding the bone in the middle, but thats just time consuming and annoying.


1 Like

Indeed this is a problem, we need a wireframe mode to be able to select bones without having a surface to click on, to be able to click just over the wireframe.

@Hypersomniac may chime in and tell us why is this happening, I think this is indeed important :slight_smile:


1 Like

Just noticed this today, and it’s incredibly frustrating. Is there any news on this?

I always use xray + display-as-wireframe in 2.79, because without xray the armature is blocked, but with xray it’s too obscuring if solid.

Wireframe display for Armatures was added to Object Mode, but not Edit Mode or Pose Mode yet. It requires deeper code changes.


It’s a pity because it’s not so important for Object Mode, but it is super important for the other two modes, to be able to rapidly select a bone inside a bone, having the click to ignore the surface of the bone and select the nearest wire to the click.

I hope you can get them back soon! :slight_smile:


We made the wireframe mode display like the (now removed) Transparent Bone option.
The selection was broken but now you can select the bones by clicking on their outlines in this mode. Which (for selection purpose) has the same usability as the old wireframe mode.

Then the biggest problem should be solved already! :smiley:

That is great, I’ll test it asap.


What’s the situation of this issue? It’s 3 years later and I can’t still find a way to make these semi-transparent octahedron bones in Pose Mode. Am I missing something?

Just to throw some info into the fire, you can also alt click over overlapping bones and it will give you a list of the options of which bone you want to select.

This doesn’t solve the issue but it is helpful !

What is this feature called in keymap? I’ve set Alt-LMB as rotate view (like in other 3D software) so it doesn’t work for me.

Sorry not sure, but nothing some digging couldn’t turn up. The same exists in the 3D viewport as well.

Under viewport display for the Armature object, set “display as” to wire. Suddenly, the Overlay menu has a bone transparency slider! UI designed well??? :person_shrugging: