Why Eevee with zoom up cause broken mesh for layered parts?(solved)


#1

I do not know, if it is better to report as problem or it simply my setting problem.
But I could not find to manage way about Eevee, when zoom out (to render full body) for animaiton,
the frame often show really ugry mesh for actors.


At first, I though it is because my modifier or driver of armature setting cause problem etc, then I test with still render. without modifieres . and remove keyframes too.

After all It show same problem for layered mesh part. It enhance when I render with more large pixel size.
close up OK. then gradually zoom out, this issue should happen about eye or tongue mesh or, body may show stick out from cloth.

I tried to not enhance problem,(some user may feel bad)
but if I use more wide 3d view, and render more large resolution,
it enhance this problem. eye actualy stick out from body. tongue, teeth parts are shown.
At first I thought it only happen when I see in 3d window,
but actualy rendered image show same problem with resolution setting.

Is there way to avoid this problem, or good workflow?


#2

And it happen 3d viewport with Camera, even though I use solid mode. I usually set same Focal length for Camera and 3d View. then when 3d view is perspective this problem not happen.

but when 3d view set camera, then select camera, and zoom in,meshes show as broken.

but if I render by cycles,with use same setting, there is no problem about render, and 3d view
(use same camera for 3d view, then change shading as render(cycles)

so it happen with Eevee render, and 3d view port with Camera.


#3

have you tried changeing the clipping distance? (N-Panel>View)


#4

Yes. I know why you aski it. I often change clipping dsitance min value to 0.001 ect , to edit mesh easy.
so it not matter. and I think, it not cause this issue. it only happen with camera view and Eevee render.

I remove depth of FIeld (I used target (Null) parented figure bone). but it can not remove problem,.
and if I can not use DOF as usuall way, , I may not hope to render with Eevee,

And I test almost same scene, with 2.7 (I can not use saved scene in 2.8)
It never show such problem with view port. with smooth shading too.


#5

This really looks like a z-fighting artifact.

I would gladly investigate if you can have a smaller file exhibiting the same issue.

Also are you on MacOS?


#6

Hi really thanks you try to investigate this issue. About my case, I am windows PC with Nvidia card.
but I can not say, it is small file. After all I once remove all camera, and check all keyframes ,then
add new camera, remake scene again. It remove this artifact, but I still see, when zoom out, figure eyes move side.

It is really strange effect, because with camera zoom out, eyes as if actor clear see another side.
(eye posed perfectly center and watch camera direction, and zoom up no problem,)

I check armature driver , but I did not set any constrain or track with camera. and it is new camera,.

I also checked same issue of blender BF bug reports, but as you said, many issue is reported as mac PC.
but I sometimes see almost same issue with my PC (windows 10) .

anyway, If I can re-produce more clear case with small file which I can offer, I report again.
and if I find same issue, (camera view often cause strange issue with pose figure) I report here.
about this scene, unfortunately I can not attach blend file. (so I could not report it)


#7

I think, I could reproduce it with suzane


it is camera view (without lock) but zoom in.

my camera lcoation is almost -8m (Y), then monkey locate world center.
and camera Clip end is 300m (so it should not cause this issue)

I attached blend file link of my drop box. check it please.


#8

Same setup in 2.79 produces the same artifacts.

The issue is not the clip end but the difference between clip start and end, and where the object is inside that range.

I wont go into details but the precision of the depth buffer is way better near the clip start (precision is not uniformly distributed along depth). if you put the clip start very low, it puts all this precision near this value.

I’m sure other people will explain zbuffer precision issue better than me. Or look it up on the internet.


#9

I see. Thanks you take time. I have never thought about clip start and end seriously. Usually just set
low min and high max. After see this problem, I changed both as more wide range. it seems wrong.

I check again about the animation file camera setting. :slightly_smiling_face:


#10

it’s better to set the range to what you need, not too wide. but that’s an issue with any software due to the limit of numerical precision


#11

Hm I also just used to crank the range wide whenever I had issues. Useful to know that the distribution is not actually uniform.