Voxel remesh in 2.9 has random 'pores' (pics), is there a fix?

I’ve searched on this topic and haven’t seen it addressed anywhere.
When I voxel remesh a somewhat complex shape, I always get several (sometimes a lot) random weird holes (I’m calling them pores) in the result. I don’t think they are ‘poles’ because they occur even with pole correction on.
Below are a couple pictures of before remeshing and after, also showing a larger pore ‘blowout’.
I really need the voxel remesher (it is critical to my workflow) but I can’t fix this problem. I’ve tried everything from subdividing or decimating the original mesh and smoothing, relaxing, etc. with no luck. The ‘pores’ just move to different locations. If I increase the voxel density the pores just get smaller and often (but not always) different locations.
I’m really hoping somebody can help with this because I’m at a dead stop in my project until I can fix this.
Anybody else have this problem? Is it a known problem that I’ve missed in my searches?
Thanks any help is super-appreciated.

Original triangular (fully manifold, no intersections) mesh and description of ‘pores’ and ‘blowouts’:

1 Like

This looks like a limitation of the currently implemented OpenVDB version. I know that the comparable Dynamesh technique in ZBrush can also have difficulties in specific scenarios like these.

Did you try to close the holes in Edit Mode, then perform a new Voxel Remesh with a higher density?

Did you also try to change the size of the mesh before (re)meshing? Don’t forget to apply the scale using Control + A in Object Mode.

By the way, I’ve moved your thread to User Feedback, as the Development category is not meant to report issues that are encountered.

Thanks very much, yes I tried the above suggestions. I can close the holes, but I can’t get rid of the ‘blowout’ projection. I am looking at the openvdb, and will take this to the user thread, thx.

1 Like