Visibility toggle for lights is not logical

In a scene with dozen of lights, we don’t have an option to hide only light gizmos but still see lights affecting the enviroment.

Now when you uncheck visibility (Eye) for lights they disappear from 3D View, but also stop lightining the scene.

I think visibility should be just for the light gismo in the viewport, and emiting or not should be a render toggle behaviour.


Have you tried Overlays -> Extras?


Yes, but tt does not hide ONLY lights gismos.
But I think that light visibility toggle in Outliner should behave like this, not affecting light emission.

But that’s the standard behavior on all 3d apps, in fact, blender is already a little out of the standards on it.
In other 3d apps, the eye visibility of the outliner only hides the light emmission and not the giznmo, in blender it hides both.

But yeah, a separate option to hide only the light gizmos would be handy. Most 3d apps have it.

It seems that with cycles as renderer hiding the light gizmos using the Object Types Visibility menu does NOT influence the scene lighting in the rendered preview (that’s the eye menu left of the upper yellow arrow in TheRedWaxPolice’s picture). Looks like behaviour with EEVEE is different in this respect.

And there’s also a difference between using the eye icon in the outliner versus the object type visibility eye icon. With the former the light contribution is removed when hiding a light, even in cycles.

The behaviour is not consistent at all.
My proposal is that the eye toggle means hide only gismo for lights and camera/render toggle means hide light effects over scene in render (viewport or final).

1 Like

Hi i want to bring attention in this topic again because yes its annoying,
I have this scene where i want to preview that Xray effect contrlled by the empty and hide lights cameras and other not relevant stuff.

So i hide those, but it does change look a lot.

and extras hide the empty too

So yes, turning off lights when its Gizmo/icon its hidden its a curve ball, i can understand the term “hide by type” its a preset for hidding but its as i said a curve ball, technically the term its correct, but UX wise its a " meh :frowning: " feature, because if i choose to select and hide the lights it will also turn off so there is no way to filter some icons from the viewport to work in a more clear environment, this all or nothing its not very flexible.

Maybe all object overlays should be listed too, directly there or in a menu

Or add a third row to hide only overlay


Is there a solution for this meanwhile?

I have 5 lights in the viewport that I don’t want to see while editing my models and scenes. But when I disable them in viewport (either by the Eye or Monitor icon), they are also OFF in the Rendered Preview, which makes no sense as they also are still ON in my final rendering. I just use 5 lights. I can image how this looks in even more complex lighting scenes.

If this still is an issue, please fix it.

1 Like