Vertex paint mode is confusing

Vertex paint mode is confusing to use because default vertex color are the same as the default brush color.
When you switch to vertex paint mode the first thing you do is start clicking to paint but it does nothing as the color of the brush is the same as the default vertex color. The situation is worse than in 2.79 because in 2.79 you could see the brush color in the tool shelf by default. This is especially confusing for new users.

Possible solutions:

  • Change the default vertex color to another color, like more grayish (best solutiion IMO )
  • Open the Tool setting in the header when switch to this mode to show in evidence the color

Asked to death already. :upside_down_face:

1 Like

Absolutely - this is a no-brainer IMO.

The tool settings header is visible in the Texture Painting or Sculpting workspaces. You can enable this in any workspace, and also you can find these controls in Properties > Tool Settings.

1 Like