Transparent background option is under a heading named "Film"

PROBLEM
You want to render out sprites or icons with transparent background. Where do you look?

Apparently, under “film”, which is a word that I don’t think is appropriate in this day and age even if you are rendering out a movie…

The only reason I found out, was because somebody told me. I do not know how I would have discovered this on my own, because only the tool tip hints that the toggle actually has to do with the background.


SOLUTION

  • Rename the “transparent” toggle to “transparent background” (this is a given).
  • Rename “Film” to Background (or something more modern at least?)…
  • Or, perhaps better yet, move the “transparent background” toggle to the Output - Output category (which yes, sadly is seriously called that), because you clearly see an RGBA option there, but the switch that makes it usable is in another castle. :slight_smile:

EDIT: Is there any reason for the RGBA option to not always force the background to be transparent? Shouldn’t it go without saying that if you don’t want transparency, you switch to RGB? Is the whole explicit transparency toggle really necessary at all?

5 Likes

As a note, compositing could result in any number of uses for saving transparent pixels unrelated to the background of the render.

1 Like

A nice solution)
I was also proposing to move Color Management to Output Properties, since it is more related to output setup than to, actually, Render setup (it influences after pressing Render button as far as it is postprocess setup), to make Render setup list less overloaded.

From other side, this “Transparent” checkbox currently influences render setup (it influences before pressing Render button - render starts with transparent background or not), so it may need to be rewritten a bit to work in postprocess way (to bring ability to switch transparency back and forth on already rendered image with this checkbox) in order to be moved to the Output section.