That goddamn dyntopo warning

Every time I add a new primitive object it gets auto-generated UV map. Which means that if I switch to sculpting and turn on dynamic topology, I get a warning that dyntopo will destroy UV data and vertex colors and whatever. EVERY. TIME. There is no way to turn that off. There is no way to send that warning to the console log, where it belongs. There is no way to turn off auto-UV. You have to uncheck it every, goddamn, time.

Which genius in the devteam thought this is a good idea?

You can see where I reported cause I thought it was a bug. Looks like it was done on purpose even though it’s annoying. Delete your UVs and don’t add any til you need them.

@billrey time for that popup disable option?

Just to be clear, it was not ‘added’ - it was always there.

But yes, there could be an option inside that popup for it to keep it on for the entire session, or something like that.

1 Like

Um, no, it was added.
In 2.79 objects are not auto-unwrapped.
In 2.79 the dyntopo warning appears, but also purges the UV/vertex color data (as it should), so the next time you turn dyntopo on, the is no warning.

These are 2 changes, both for worse.

No on both accounts. The behavior is the same. The UV map itself was not purged when enabling Dyntopo in 2.7x either, and you would have to remove it.

Making new objects UV mapped by default is, in the vast majority of cases, not a change for the worse, because you can add an object and immediately add shaders and textures.

Yes there can thought of solutions to make the workflow nicer, but no changes or regressions for this feature was done in 2.8.

On the first one - correct, I was wrong, it’s not removed by default.

For quick preview of textures there is box projection.
For actual use… no one actually uses primitive objects as a final thing, so there is no point in auto-unwrapping them.