Switching over to Cycles after building in Eevee, Cylces failing


#1

I recently started working on a simple project just to get used to 2.8. Everything was created in Eevee, using nodes. When I switch over to Cycles, it will not render. It seems to be something specific in my project. Is there anything that Eevee will render but Cycles will not?

To test whether it was my project or not, here is what I did.

  1. Load the default startup.
  2. Check that the render engine is set to Eevee.
  3. Add a node material to the default cube.
  4. Render the scene with Eevee.
  5. Render switch the render engine to Cycles.
  6. Render the scene.

This all worked. But on my project, Cycles just sits, appearing that it is rendering a frame. I left it to render overnight and it showed that it was on the second pass but nothing was showing up as rendered.

If there are some settings in Eevee that will not render in Cycles, is there some way for Blender to check this before someone starts a render. Maybe a warning screen saying “[blank] cannot be rendered in Cycles”.

Maybe its something I’m doing? Although, I have mostly default render settings. Thanks for your assistance!


#2

Sounds like a bug, best to handle those in the tracker:
https://developer.blender.org/maniphest/task/edit/form/1/

You can narrow down the cause of the problem, by removing objects, materials, nodes, settings, … until you find what exactly causes the problem.


#3

Thanks for the info. I suspected it was a bug but haven’t done enough with Blender yet to confidently know the difference between Blender causing a problem and myself causing one :wink:


#4

Before I submit a bug. I found out what seems to be causing it. I’m wondering if maybe these numbers are just too hard to calculate for my system? It seemed to be unable to render anything after I changed the Hair Shape settings. Edit: Nevermind, I tried lowering the numbers and it still had the same result. I’ve submitted a bug report.