Starting Blender 2.8 in remote desktop session

Hi,

With previous Blender version I could start them in a remote desktop session by copying the opengl.dll from windows32 to the Blender folder. (using remote desktop in windows 10).

With blender 2.8 it doesn’t work.

i also tried a bat file that close the windows 10 session and then try to open Blnder but it didn’t work either.

Is there any way to open the 2.8 version in a remote desktop session?

thanks

1 Like

The software OpenGL that comes with Windows is very old, you can download a DLL with a newer software OpenGL version.

However for good performance it’s better to avoid RDP and software OpenGL entirely, and find another software that supports using the graphics card in the machine without any DLL hacks.

Hi brecht. Thank but i saw that link already and the dll is the same opengl dll from 2014 and it doesn’t work with Blender 2.8.

Other remote desktop app do not work anymore with windows 10 I tried team viewer, thight vnc, ultra vnc and tiger vnc. None of them worked at all to login in a windows 10 pc with latest update (I have 1607 as well as 1803). Maybe team viewer was working to log but couldn’t launch blender 2.8 and was slower than windows remote desktop.

When I log on a remote computer on my render farm it’s mostly for debugging and testing render speed, it’s not for working intensively and it is very useful in my day to day work.

Just get a newer version of mesa and you should have no issues on RDP. (well besides it being sluggish… )

edit blender seems a little crashy with the latest version, but iv’e been using 17.3.6 and that seems fine-ish… :slight_smile:

Ok thanks Lazydodo. can you explain what is mesa? I’m not sure to understand the description on Github. How do you install it with blender? I tried to just copy the opengl32.dll from Mesa x64 folder to Blender 2.8 folder an dI could load Blender but as soon as i press F12 it crashes. I tried both latest version and 17.3.6 with almost same result (only differenc eis the latest one also asked for another dll that i also copied the same way but it crashes to on F12.

I used the cmd provided and it copied a few more files but still crashes on F12. any idea? I can’t wait to try to launch some render on my 8 gpu rig with Blender 2.8 (the renders did work in 2.79).

It’s a software implementation of opengl, it has bugs, blender has bugs sooo sometimes it works, sometimes it doesn’t. don’t expect any official support on this setup.

Mmmmmmmmh… thanks.

Now it works even with rendering without crash. I think I just had to restart to prevent crashing when rendering.
I just tested it with latest mesa: https://github.com/pal1000/mesa-dist-win/releases
And Blender 2.8 alpha and it works. When installing mesa I chose yes to all.

All this is pretty odd. Remote desktop, since Win8, has supported hardware acceleration (both ends need to be at least Win8).

Here’s an example connecting to Win10 from Win10 - graphics card from 2011:

I believe this is only supported by Quadro drivers, and not Geforce which most users have.

Huh… you’re right. When connecting to my 1070 laptop it pops up the OpenGL 3.3 error dialog. I guess the consumer drivers don’t have it. Neither do AMD FirePro W2100 cards/drivers.

I guess I never noticed before when connecting to my work machines. DirectX works and I can request a DirectX12-level device on both; but not OpenGL… hmph/lame.

Latest versions of Mesa don’t work anymore for this purpose. I found out that 18.2.1 is working except that Eevee becomes really slow to the point of being unusable. So there is no way to use any computer that doesn’t have a monitor with Eevee so far.

I think, is it possible to provide a disable opengl option that allows remote computers to run the Cycles renderer on Blender for remote rendering?
After all, the current network rendering plugin is not perfect, and the remote computer used only for rendering does not require OpenGL functionality.

I believe Cycles rendering in background mode should already work in such cases? We don’t use OpenGL for that.

We also have software OpenGL emulation for Windows here, but it’s very slow.
https://download.blender.org/opengl/software-emulation/

1 Like

If having Blender opened before accessing the computer remotely (I use macbook air > Windows 10), I can use Blender fine. So the issue is only when starting a new session with blender. hmm!

blender just needs to be started on the console session.which you can do remotely if you’re ok with being kicked out for a few seconds and have administrator rights.

how?

Make a batch file with this in it

tscon 1 /dest:console
C:\wherever\blender\lives\blender.exe

when you run this as administrator it will (the administrator bit is important)

  1. Kick you out of your RDP session
  2. Connect to the console session
  3. Start blender

you’ll have to wait a few seconds for blender to start so don’t reconnect too quickly or you’ll get the opengl error again.

the session number (1 in the batch file above) sometimes changes , you can run query session on the command prompt to get a list of current session here’s my current list

 SESSIONNAME       USERNAME                 ID  STATE   TYPE        DEVICE
 services                                    0  Disc
>rdp-tcp#88        lazydodo                  2  Active
 console                                     3  Conn
 rdp-tcp                                 65536  Listen

so i would put tscon 2 /dest:console in the batch file

1 Like

Just got this information from NVIDIA regarding remote desktop with NVIDIA GeForce.

Due to most everyone working from home, a frequent request was for NVIDIA to provide Windows Remote Desktop support for NVIDIA GeForce GPUs, a feature that has previously only been available on enterprise Quadro boards.

You and your customers will first need to log on as an NVIDIA Developer to get access, but after you do this link will enable you to access the software you’ll need: https://developer.nvidia.com/designworks

It will require you to use GeForce drivers R440 or later. Once you download, launch the executable as administrator on the machine which runs the OpenGL application to enable OpenGL acceleration. A dialog will be displayed to show whether OpenGL was enabled and if rebooting is required.

Future GeForce 440 and 445 drivers will have the capability built in, so you won’t need this patch.

3 Likes

Can confirm it works!

1 Like

This has been an issue bothering me for such a long time! Thank you for following up after all this time with this awesome news!