Shift+F for Flipping Normals

I have a workflow involving BrickLink Studio to Blender to Unity to Tabletop Simulator. However, some of the new bricks exported to BrickLink’s Database often end up with no or inverted surface Normal data.

It is a pain to have to find and select every single similar object only if it has incorrect normals and press SelectObject->EditMode->Mesh->Normals->Flip->ExitEditMode for each one. I suggest a tool which warns about potential incorrect normals for an object (perhaps on import).

I also discovered that by default Blender has no keymapping for Flip Normals, so I added Shift+F which made it easier. However, I have to either make this change in my default project and also every other .blend file which isn’t based on my default project.

I have the Material Utilities Add-on enabled and with Shift+Q it enabled me to select each material individually and check if Backface Culling is enabled (disabled by default). This is especially an issue when importing into Unity directly through FBX.

Unity should not have to be burdened with doing a backward pass in the shader (and it calculates backwards normals incorrectly as if they were forwards too). Equally, Blender does not have to share the same burden, but instead it does both passes. It can be confusing as to why it appears correctly in EEVEE but not in Unity Standard or StandardCullOff.

Otherwise, great work with all the integrations, I have loved using Blender since early days and have watched it evolve into the sophisticated engine it is today. Keep up the amazing work!

a few notes:

  1. this forum is for Blender module teams to reach out to contributors - development questions are welcome- but this appears to be a feature request, which is better suited for a site like RCS

  2. there are a lot of people who use Blender who are not game developers, and many others who are game developers but do not use Unity. What you would like to be the default would only appeal to a subset of Blender’s userbase.

  3. It appears that the real problem is that BrickLink studio is exporting data with bad normals. Have you tried contacting that developer and asking them to fix their exported data?

  4. You do not have to set a hotkey every time you start a new blend file, just save your preferences. Auto-save preferences is even enabled by default, so i’m not sure how you wound up with this idea. Keymaps are not saved in your startup.blend, they are stored in your userpref.blend, which is loaded regardless of the file you’re opening (old or new).

Blender has the Shortcut ( Ctrl-N and Shift-Ctrl-N) for this, read the manual

That seems to be un-updated. Since 2.8 CTRL+ N is for “new file” menu. Recalculate normals is now SHIFT + N, which would probably work fine for op’s situation, and the ALT+N pops up the normals menu which includes the flip option.

1 Like