Rigid Body World Cache broken in Blender 2.8?

Hey Everyone,
I cannot clear the Rigid Body World cache in Blender 2.8. Blender does the calculation once, on the first playback, but then I’m stuck with it. If I change parameters e.g. of a Force Field, the Rigid Body World doesn’t update. If I try to manually delete the cache nothing changes. Even if I bake the animation, or recalculate it up to a certain frame, nothing happens. I can see the occupied memory changes but Blender is still stuck with the cache of the first calculation.

If I remove the Rigid Body World and create a new one, I can get it to do a fresh calculation on the first playback, but then it’s stuck again. This process also seems really inconsistent. Sometimes nothing happens when I add a new Rigid Body World, sometimes it does one fresh caclulation.

I tested it on two versions of Blender 2.8 including the current one and with a fresh blend file. The error always occured. In Blender 2.79 everything works fine. Seems like there is some issue with the cache. Can anyone reproduce this on his/her machine?

Greetings and happy developing :slight_smile:

2 Likes

I just found out, I can get the Rigid Body World cache to update in Blender 2.8 by deleting any bake and then toggling Gravity. This seems to invoke an update, but only if toggled after the bake is deleted. Any other changes to parameters of any physics objects don’t make the cache update, even if there is no bake stored.

I guess this is not the intended behavior, since it should update the cache on any change to the physics system, if there are no bakes and especially when “Delete All Bakes” is called, which it currently does not, at least on my machine.

I confirm that Rigid Body World does not update properly, please, fix it!

I can also confirm that it does not update. For me it doesn’t help changing gravity settings to clear cache, so I’m stuck with the first bake I make.

I had the same issue, but toggling gravity works. So I would “Delete all bakes”, toggle gravity off/on and then “Bake all dynamics” and the simulation updates correctly.

I can confirm this bug still exists!

Unfixed as of 2.82a
This is how I get it:

  • set up an animation, bake, play, works.
  • now change something on the dope sheet that should affect the outcome greatly, delete bake, bake again, it bakes surprisingly fast (because it doesn’t) and nothing is actually changed.
  • if I change any rigid body parameter then it re-bakes as it should, then I change it back and re-bake it again and now it works as it should, but the step of changing something and then changing it back so blender can just update the simulation isn’t right.

Isn’t deleting bake and then baking again supposed to be some sort of hard reset for the simulation?
Why does it reuse old cached bake then?