[RESOLVED] Grab lag - could it be fixed in 2.8?

I attached a video to demo what this issue is. Shorly - when I use “drag&drop” style grab to tweak vertex position it moves not at the same time I make mouse/stylus move - just after some cursor offset. That’s really really annoying and unfriendly “jumpy” behavior.

This grab lag issue was in Blender for all time I see it but may be new 2.8 release is good point to fix it.

p.s.: At the same time Sculpt mode Grab has absolutly zero lag - I wish ordinary translate-grab was like that.

p.p.s: No need to advice me to use Manipulator or G key - it’s waste of modeling time in case of just tweak vertecis.

1 Like

A dev can correct me if I’m wrong, but I don’t think this behavior can really go completely away.

If the grab threshold was set to zero, Blender wouldn’t be able to distinguish between a click for selection and a click and drag for moving because you most certainly move the mouse by some small amount every time you click - whether you mean to or not. Sculpt mode has zero lag, because you aren’t expected to select anything with the brush. I know you distinctly say that there’s no need to advise you on using the g key, but if you want to move less than that offset (threshold) that you’re seeing you have to use the g key.

It may be possible to make the threshold smaller, but it will not go away without a keypress.


Thanks for a post. I see what you mean. The question is about overal “jumpines” of grabing not in that I want to move vertex below that threshold you mentioned. It’s just like stroke lagging for cintiq-like displays, or lazy-mouse function that is no need in this case.

It’s a pity that it’s probably impossible to combine tweaking(on sculpting grab manner) and modifying mesh within one edit mode.

It’s jumping to the position of your mouse cursor once you drag past the threshold. Would keeping the vertex offset from the mouse cursor be better? I’m trying to think of what the downside could be.

It would be just like lazy mouse mode, imho it wouldn’t make grab situation better(.
It seems like I’ll have to get used switching between edit and sculpt mode

p.s.: Actually situation with sculpting brushes (especially with sculpt-grab) is absolutely opposite to edit-mode-grab: sculpt grab has no pressure sensitivity for “Strength” and no “Propotional Editing” feature that edit-mode-grab has since beginning of blender time. It was a code project last year about sculpt-grab brush improvements but it failed as far as I know.

Adjust the Tweak Threshold in User Preferences > Input.



It helps! Thank you so much, Pablo!