Regarding Library Overrides, some notes

I tried the libary overrides and some things that I thought were expected to work are not working, but maybe they are not ready yet:

1.- Modifiers: it’s way of work is a bit weird, I have to override the object, then go inside the object to the data override the data and then override the modifiers (or something like that) but it’s a bit weird to get to make them work.

2.- Modifiers 2: I tried with a subdivision surface modifier and it worked, but I also tried with an alembic file, and the Mesh Sequence Cache does not allow the settings to be override, not sure why, for example the time offset.

3.- Materials: it’s weird but they are still not working, I can override the material (after doing 3 or 4 overrides in the outliner) but if I save that file, I close Blender, I open it again, and the material is not override, not sure if this should work already or not yet.

I have to say that I have not tested armatures and animation yet, it’s the next thing I want to test :slight_smile:

Anyways, thanks for your work on this @mont29 :slight_smile:


Thanks for the feedback, but indeed not everything is expected to (really) work yet, and other things work but in some un-easy/not-user-friendly ways. :slight_smile:

Also, not sure which version of blender you tried, so will answer based on current master.

  • Modifiers: you do not need to override the obdata, overriding the object is enough. And everything should be overridable (unless maybe the RNA for alembic cache modifier is not defined at the same place as all other modifiers…).

  • Materials: you can make them work to some extent, but it’s tricky (you have to assign material to the object itself, or you also need to override the obdata. And overriding of nodes is not yet really implemented, so you won’t be able to do much with an overridden material anyway, currently).


Thanks for the clarification @mont29 !

It’s good to know that it’s clear that right now it’s not user friendly, this means this whole workflow will improve :slight_smile:

So regarding the two things mentioned:

Modifiers: then something happens with the Alembic modifier, @sybren are you aware of this? :slight_smile:

Materials: Well, an overridden material may not be useful if we cannot override nodes, but being able to override the specific material in a scene it’s important, so if there is a way, at least there is a way for the time being :slight_smile: I will test it.

We’ll eagerly wait for more news in the override front of things :slight_smile:


Aware of what? Not sure what you mean here.

It would be pretty useful to have a tutorial showcasing the usage of Library Overrides.
As of now, it seems like there are zero knowledge about this feature in community-driven tutorials and no mentions of them on Blender Cloud. I use proxies pretty often, but override button is literally always grayed out for me. Having more people try the feature will increase feedback quantity as well.

1 Like

I mean that the Mesh Sequence Cache (alembic) modifier is not overridable, what @mont29 said in his answer :slight_smile:

@JuanGea but… he doesn’t say that. He just hints that this could be the case IF the Alembic modifier does something different than other modifiers when it comes to RNA.

1 Like

Just checked, settings exposed there are from the CacheFile type of ID, not modifier settings themselves, so indeed they are not (yet) overridable, will add them soon (but you will still then have to also override that cachefile data-block first).

1 Like

Thanks to the both of you for clarifying this :slight_smile:

Hello, I hope I put it in correct thread.

I have feedback regarding behavior of creating library override from Object > Relations menu.

Currently it’s follow the fashion of proxy whenever we call make library override menu, which is, it will show the list of all objects that we want to override.


But whatever we choose from that list will return true and recursively create the exact hierarchy as original (which is expected).

My question/feature request is can we bypass choosing any object for library override? Or maybe we can have like override all and override from selected

Thank you.

I think, based on what @mont29 said, that all this UX will be re-designed and vastly improved, right now it’s a bit user un-friendly :slight_smile:

1 Like

If I understand your answer correctly, material overrides should be possible. Our use case is this: link an object and link a material from a ‘shader library file’. Then override the assigned material of the object with the one from the shader library.
You can do this, but – as @JuanGea mentions – when you reload the file it’s gone. Both the object and the object data are overridden. And I also tried to assign the material to the object, but to no avail. I tried in the latest build bot build.

Can you confirm this is not working yet? Or I am doing something wrong?

With current master, if you override the object and assign material to the object and select a new material for an existing slot, it should work.
Same if you also override the obdata and assign material to obdata and select a new material for an existing slot there.

Adding new slots won’t work though, and material properties themselves are mostly non-overridable currently.

1 Like

If overriding the whole material is possible, then it’s great news, because that means that we can make the actual material local and completely modify it as a whole new material, that’s a solution for the time being until a more complete solution is implemented :slight_smile:

Thanks for your quick reply. Unfortunately what you describe doesn’t work for me. I can select a new material for an existing slot, but it’s lost when you re-open the file. I have both the object and object data ‘overridden’.

Tested with this version:

That was my experience too, are you trying today’s buildbot to see if something changed?

Just tried again in the latest build of 2.92 alpha (, still the same problem. The material assignment override doesn’t ‘stick’.

1 Like

@mont29 should this be considered a bug since what you described is not working as expected?

Yes please create a report then, with all necessary info and data to reproduce.

@mont29 said and done :slight_smile:

I hope this can be fixed before 2.91 release :slight_smile:


1 Like