Pie menu and view navigator shortcut is not available with Scandinavian keyboard layouts

Note: Just found out that Blende 2.8 maps Scandinavian keyboards as UK/US keyboard layout, so many keys are mapped wrong, but the god thing is that ` can be accessed with the æ key.

In blender 2.8 the shortcut for the pie menu is ` (don’t know if it is new) but that key is not available on danish keyboards (most likely on all Scandinavians keyboards, Denmark, Sweden, Norway, maybe also Finland), you have to push shift + the key with the ` symbol on, followed by a letter to make it. Depending on the letter you type, it will write something different. Example with w it will be `w like expected but an e it will make è. There is no way to type a single ` nor a single key for it on Scandinavian keyboards.

Because of this the ` key is not good for shortcuts on a global scale.
Alternative maybe the ’ key could used, but i don’t know how easy that is make on other keyboard layouts but it is a single button press on the Scandinavian keyboard layout.

I think that the pie menu its an essential shortcut which should be available in every country, with the default shortcut settings.

I know I can just change the shortcut to something custom, or change keyboard layout (witch i think is ignoring when you have to switch between programs). There is no button to get the pie menu, it’s only working with shortcuts, so it should be there for every one.
Its not making any easier for beginners to learn the program if the impotent shortcuts is not available from the start and you have to figure out how to change before you can use it.
That’s the point I’m trying to send to the developers.

Other shortcut witch uses ` is of-cause also a problem, like “view navigator” and so on.

The Swedish keyboard layout, the danish layout has the special æøå keys witch is equal to the swedish âôå, else the same.


I have a Scandinavian keyboard as well, and the pie menu key works as expected. It’s mapped to | (the vertical “pipe” symbol on the uttermost left of the number row, just below the Escape key).

If you have any problems with it, please include at least the version of the operating system you’re using as well as the Blender 2.8 release. ( I’m using the Ubuntu-based Linux Mint distro, btw.)

I know it’s old but i have had the same issue, and it doesn’t seem to have changed it the recent 2.9 release.

I have a Scandinavian keyboard as well and the pie menu is currently binded to the “æ” and will not show up when pressing that same button in key-mapping (which ofc. makes sense as explained by OP).