Particle System Emitter Visibility Toggle

Does anyone know how to hide the particle system emitter?
There seems to be a disjointed workaround which involves hiding the duplicator in the emitter object properties, which also hides the particles. After a bit of clicking and unclicking it appears to work. Quite frustrating.

Any fixes on this?

Disabling “Show Emitter” should be enough. Just tested it in the latest build.

Hi Pablo. Thanks for your input.
I will download todays build and test it. It has’nt worked for me in all the builds, including yesterdays build.
I will let you know later today once I’ve tested.


Hi Pablo.

I still cannot hide the emitter in the latest build. When I uncheck “show emitter”, the particles are hidden. When I re- check “show emitter” the particles are no longer shown.

Not sure if this makes sense?

There is some kind of refresh bug when you toggle the option, that should be fixed.

1 Like

Hi Brecht.
Thanks for your reply.