Outliner's default visbility toggle should override the other hidden ones

Disclaimer: Someone must have posted about this before (perhaps even me), but I couldn’t find it using search right now.

PROBLEM

  • The Hide toggle is the only visbility toggle shown in the Blender outliner by default.
  • It’s the only thing new users see, and they’re always surprised when hidden objects appear in renders.

SOLUTION

  • Disable in Viewport and Disable in Renders are advanced features.

  • Disable in Viewport, in conjuction with Hide in vewport, is a very advanced feature.

  • Whichever single visibility option Blender chooses to show a new user by default, that should hide the object from both the viewport and renders!

EDIT: My original suggestion was this, but I changed the wording now…
image

3 Likes

I should emphasize here that the checkbox also should not be shown by default, since it makes the stair stepping of the hierarchy more difficult to read:

bild

To me, that is the wrong solution.
Users may want to hide things in viewport and see them at render.
An automatic override would simply remove that ability.

I prefer to simply enable Render restriction toggle in default startup.blend file.

Let me interject:

Expert users may, and they still could. New users, however, wouldn’t have to Google why all of their hidden stuff suddenly show up in their renders, because the UI sure didn’t provide them with any clues for it.

1 Like

No, you don’t have to be an expert to want to hide a ground or some walls of a room in viewport but have them occluding environment in render.

Why adding an artificial toggle there between Expert/Newbie when problem can simply be solved with a better default ?
Viewport and Render toggle are on same line. User can disable/enable both in one single movement.

1 Like

This was my suggestion before UI Paper Cuts was closed.

Hide hierarchy in Outliner by default.
Example how it’s work in Modo
also hiding in viewport by H affect globally on hide object
(it hides from rendering too, in blender you need to search that object in outliner and manualy click camera icon if it turned on in Restriction Toggles),
and by clicking on eye in outliner it doesn’t appear until pressing Unhide (U in modo) in viewport

Similar as Blender Collection hiding in outliner but for all objects hierarchy