MacOS Catalina 10.15.1 blender 2.8 & 2.81 got display issue

Today MacOS upgrade to Catalina 10.15.1 . blender 2.8 & 2.81 got display issue

imac 2017, Radeon Pro 580 8GB, 4.2Ghz Intel Core i7, 64GB 2400 MHz DDR4

issue find When Show “Viewport overlays” is on

Are you saying that this error occurred when you upgraded from 10.15 to 10.15.1 ?

yes
upgraded from 10.15 to 10.15.1 camera light object become purple blue color. delete the default startup file, and restart again. the object also is purple blue color. when “Viewport overlays” is off . the object become grey color

Ugh, that sounds like a degraded ogl driver :confused:

Not sure if there is any dev with Catalina 10.15.1 installed (or 10.15 to begin with)

I just upgraded from 10.15 to 10.15.1 but I don’t see this problem. Tested on a machine with:

Radeon Pro 560X / Intel UHD Graphics 630 1536 MB, 2,3 GHz Intel Core i9

i just updated to 10.15.1 and also got hit with blue viewport display issues.

things i’ve found:
-it appears to be connected to overlays, the viewport is fine if overlays are globally turned off (which isn’t very productive for actual use)
-‘load factory settings’ makes the issue disappear, and i can in fact load other scenes after that and they will work ok, however i need to reset to factory settings every single time i open blender now; not even save ‘save startup file’ will allow the fix to persist across sessions. and of course losing all preferences/key bindings/addons etc on every single time i open blender isn’t very feasible either.
-luckily it doesn’t seem to affect any 2.81 betas on my system, but i have a separate viewport performance issue in 2.81

i have a bad feeling the only way through this mess is going to be to roll back to mojave, and think hard about whether macos in general is worth the hassle going forwards - i’m sure this situation is only going to get worse :frowning:

edit: semi good news - blowing away blender’s application support folder for 2.8 and starting fresh that way seems to have more permanently fixed the issue for me. hopefully it doesn’t come back!