LookDev mode looks washed out!

i noticed that the lookdev mode looks washed out now compared to what the old alpha version had, it’s like it doesn’t use environment lighting for reflections…i know there were changes made to make EEVEE and Cycles to match as close as possible…so i was wondering if this is a bug or the result of that?

same simple scene setup.

1 Like

I’ve been testing stuff since alpha but haven’t seen such abnormality. Things with low roughness values still looks like right image in my cases.
Are you sure both material roughness and specular values same? Can you share .blend file?

sure here the same test file, i reset both versions to the default to just make sure and also played with the values but the washed out look still there especially when using basic materials.


I noticed that your issue might be related to Filmic color management. (I decreased roughness value to 0.2)

Here is with filmic:

without filmic:

So maybe in alpha version you tried, filmic wasn’t set as default.

for both it’s set to filimc with none contrast, it’s what comes with the factory settings…the issue is not with the values but the built-in environment lighting,this is how it creates accurate lighting from the HDRI & their reflection passes out of the box.

@Regnas thanks,but as i stated above i want to make sure it’s actually a bug or something else.

Yes. It is expected result.
It is clearly a roughness more faithful to what Cycles delivers.

Yeah, and kinda looks like a bug. So just in case…

This is due to a change in the logic of when Color Management is applied. In the Alpha Release, when you enabled LokDev, the View Transform (Filmic) was ignored entirely (and sRGB / Default used instead), unless you had the “use scene lights” checkbox in the LookDev popover enabled. This was utterly confusing, as sometimes you would have Color Management doing its job, sometimes not, even though it was always configured as on in the interface.

Now Color Management is consistently always applied in LookDev mode, and this is the desired behavior. So you can consider that in this case the Alpha release was considered to have a bug.

See this bug report for reference.


so they changed the logic how it works internally??, i am not an expert on the subject but isn’t lookdev supposed to not have any color management and only take information from the HDRI & the light source to match the VFX plate as close as possible!

This is impossible; you must absolutely always manage the RGB encoding. There’s no such “option” to pixel management.


I was unclear in my last comment. What I tried to say is, that in the alpha, even though you had chosen filmic, sRGB EOTF - in blender called default - was used instead. Both manage colors, but yield different results.


okay. i understand know a little better,so the alpha didn’t respect the filmic color space internally which didn’t handle the reflections as accurate as i thought…but now it’s more “physically” accurate & the default now is called “Standard” …thanks for the explanation.

Could you tell me the hash that appears in the 2.80 Alpha splash screen you are using?
I have tried several old versions and none of them looks like in your capture for 2.8 Alpha.
Are you compiling/building blender yourself?

44612e07fe9 Alpha 2, yes now i do compile myself to get updates without going through the hassle of downloading each build…etc but before i wasn’t.