Lookdev mode blurry background problem

Hi,

I’d like to raise an issue of backgrounds in Lookdev mode being blurry. It may work for people who don’t know what they are doing and just want their viewport backdrop to look cool, but for past 8+ years, look development is basically what I am doing for living, and having blurry background is just making my life a bit harder.

If you spend years looking at scenes set up in photorealistic PBR manner, you get a certain “feel” for the light transport, and you quickly tend to notice when things don’t look right. One of those things is light transport mismatch between scene environment background and contents of the scene. Blurring the background creates this mismatch. You are looking at an object, or set of objects placed within an environment that implies very undefined, soft lighting and reflections, yet your scene actually receives very sharp, defined reflection and is lit by quite defined, contrasting light.

These conditions make it impossible for me to utilize the LookDev mode the way it’s supposed to be utilized, to perform a look development of the asset shading and bring it into final form. I just can’t get a correct visual reference of my object in relation to its environment. An extreme example below:

I’d therefore strongly suggest to fix this, otherwise there will be very little use for LookDev mode. In general, the difference between the appearance of the final Eevee (And possibly Cycles) output and LookDev view output should be reduced to minimum, or if possible, eliminated completely. Anything else will only result in damaging the accuracy of the look development performed by user.

5 Likes

Hi, sorry for posting my threads in the wrong category. I haven’t been here for a while, and I’ve mistaken the development category for the user feedback category since I did not look hard enough to remember this is mainly developer forum :slight_smile:

I agree it would be really nice to be able to unblur the background in lookdev mode. The HDRs that ship with blender are super low res so they would look terrible unblurred, but since we can add our own HDRs, it would be nice to at least be able to unblur them. This is mainly because you can’t get the lookdev preview spheres any other way. I couldn’t for instance switch to eevee rendered mode in order to see sharp backgrounds and still have the lookdev preview spheres.

1 Like

Bumping this thread. The issue is still present and severely limits usability of the lookdev mode. It is especially difficult to determine which direction is the main light source on the HDRI map coming from, and there’s constant general feeling of significant mismatch between lighting on the objects and environment background.

It’s quite inappropriate to simply blur all the HDRIs in the lookdev mode for completely arbitrary reason. There’s not proof it serves the lookdev purpose in any way.

I again have to bump this thread. The lookdev mode is quite important because if quick access to lookdev environment without need to create environment lighting, but it’s completely ruined by the blurry background. When will this be fixed?

I’d also agree that this would be an improvement. I like the blur feature, but other software like marmoset and substance always supply a slider value so the user can set it up as needed.

Yes, 3Dcoat, Marmoset, Substance painter… pretty much any 3D software that has blurry background option has a slider to adjust it. With the blurry background it’s often borderline impossible to tell which direction is the environment actually oriented :frowning:

I’m aware of the problem and I would like to add this blur slider in the future. But I cannot say if it will make it for 2.80 given the current state of things.

3 Likes

Are the things so bad? :slight_smile:

Bumping this thread again. Since lookdev workflow was now reworked, and is more useful, it would be good idea to get this finally fixed. It’s also inconsistent between Eevee and Cycles. Cycles in the new LookDev mode of Rendered view displays the HDRI correctly, where as Eevee still displays it blurry. :frowning:

1 Like