Lights are not displayed in Render mode Blender 2.8?

Why are not lights displayed in render mode? I already tried everything and it seems that the lights do not exist.
Is there an option that I need to activate?

I think perhaps your Object has no material or the material has nothing connected to its output.

It can not be that, because the material has it where it should be.
I’ve looked at another computer and doing the same thing in that other computer does work. But in that other one it does not work to put HDRI funds.
And I realized that the difference between my computer and that person’s is that in my case, the light icon is red and the other the icon is green. And his hdri is in red and mine in green. As if they were deactivated.

Can you share the scene and we can take a look? It should be small enough to attach to a post here.

So simple with a cube with a normal light. But I insist, it’s like the lights of point, spot, sun, etc. would not exist.

Ok, so when I open your file and change the 3dview to Rendered, it looks fine:

I can see you’re using a recent 2.80 build, so the next question would be, what graphics hardware do you have in your machine?

I’m going to guess that if you switch the Renderer to Cycles and hit F12 that the result looks acceptable?

Yeah, With Cycles the render looks good.
But with Eevee it is not seen. It’s only in light of that kind, because everything works correctly.

MacBook Pro (Retina, 15 pulgadas, mediados de 2015)
2.2 GHz Intel Core i7
Grafics Intel Iris Pro 1536 MB

What version of MacOS? You may need to upgrade to a later MacOS version in order for it to work.

I have Yosemite OS :frowning:

The new Requirements page:

says you need Sierra (10.12) or later, and then 2.80 should work on any hardware that the OS supports. So maybe it’s a good time for an upgrade (to Mojave or whatever).

Mmm I see. I’ll wait until I have another computer. I will not risk that the OS crashes and loses everything.
Even so, thank you very much: D

I am getting the same issue with HDR’s in Eevee. I literally get no reflections of any kind on my interiors when they seem to work fine in Cycles. Could someone tell me a fix?
My laptop specs - i7 8750h, Gtx - 1050, 8gb ram, Windows 10 64 bit

I don’t know whether this helps. Just try it.

  1. Create a light
  2. Make a mesh similar to that light.
  3. Parent the light to the mesh.
  4. Give some emission to the mesh based on the watts of light.
  5. Now the mesh acts as light and in render, you will be able to see it.

This might sound silly, but is the roughness all the way up on your shader material? I sometimes forget to lower the roughness, because if roughness is up to 100 percent, there’s nothing for the material to reflect - hence no light emission.

I am in a same situation. I cant locate the roughness setting and i need help.

click the down arrow next to the spheres, then check “lights”
you can also check World to add shadows.

I was getting the same issue. I increased the light power to around 10000 W (10kW) and it’s work.

1 Like

I unchecked Scene World and it worked for me. Maybe because I deleted the original light source that you get?

yes, i had the same, so it could be just a matter of scale i imagine? like if the distance between the objects is considered to be 1m or 1km you don t need the same lighting power to cross it

Guys I found out that if add a camera and then press 0 to view scene through your camera, you will be able to see the lights.

  1. Add Camera
  2. Place Camera so you can see your scene
  3. Press 0 to view through camera
  4. Start adding lights
  5. No matter if you are in eevee or cycles
1 Like