Lets fix the output video defaults!

If you set the render settings > output to FFMPEG, by default you get Matroska H.264 Medium Quality with no audio.

Matroska is broken in Blender. If you export a Matroska and then import it into the VSE it comes out the wrong length. MP4 would be better.

H.264 Medium Quality is fine - though I’d personally opt for High Quality.

I would also think that PCM, bitrate 320 would be a better audio setting.

I think this would improve Blender’s ability to work out of the box, and would be a very easy fix.