Left mouse button select in Blender 2.8

Where is the setting to change between right and left mouse button select?

At the very bottom of the input tab in the user preferences.

Also, in the api, it’s now in: context.window_manager.keyconfigs.active.preferences.select_mouse

See attached screenshot. My input tab does not have this setting?

Strange thing - my mouse no longer works in the viewports and cannot scroll in preferences dialogue box - this since trying to find mouse left click setting.

I have rebooted my pc and relaunched blender 2.8 (todays build) and mouse still does not work as explained above.

Any help?

Ok, figured out that changing key config to anything other than blender will disable mouse action in the viewport.

Anyone else on where to find left mouse button select settings?

The 3Ds Max keymap does not have option to change the select mouse anymore, it is always left as in Max. Further this keymap is not really working at the moment, you have to use the Blender keymap instead until that is fixed.

Is this really a screenshot of a current Blender2.8 build? The theme you show does not exist any longer there.

1 Like

i think he needs to delete his config and start fresh,if you load old custom keymap it won’t show the new options.
@nhoJ if u have a previous custom keymap u’ll have to either modify it with python or make a new one.

I think he’s just running an older build. Once he updates it will work correctly.

If the new preferences in blender2.8 allow to select in space between playback and toolbar, why not to add here the classic option of search?

1 Like

I thought this was a bug in a newer version - and I hope I’m missing some setting - but it appears that the old way of being able to click-select an item and drag it immediately is gone?

This is less of an issue with an entire object as this is the paradigm in a lot of software (pick object, then select what transforms you want to do with it) BUT this is a massive PITA in Edit Mode where now you have to select a point, release the mouse, then click and drag it again. This dramatically slows down mesh tweaking. You used to be able to drag a point/edge/face by just clicking on it and dragging it in the viewport - no second-click required.

Actually, as I mess with this latest version more, it seems that most of the selection mode operators are broken. There is no longer just a pick mode - instead of just left-click selecting, the 3D cursor is popping to wherever I try to select a point/edge/face.

This is definitely NOT an improvement - I sincerely hope this is an oversight.

Am I missing a setting in Preferences to return to this behavior?

Thanks Brecht.

@RainerTrummer Yes it is really a screenshot of current Blender 2.80 .

Thanks @Znio.G.
I will give it a try.

1 Like

Currently left or right mouse select is under, Edit > Preferences > Keymap > Preferences.

They keep moving the settings around and now keymap doesn’t seem to have any preferences. So where the hell is this setting now? Can’t find it in input neither.