Issue with Cycles rendering intersecting transparent objects

Hi, I just recently found that Cycles has minor problem rendering intersecting object with transparent materials. Here is a simplified example of this problem.

Start a new default scene using 2.91.2 and add a new plane with small rotation on y or x, then move up to make the plane intersect with the top face of the cube. Then give the plane a default principled BSDF and lower the alpha value. Then render in viewport.

When you zoom close enough you will notice a black line appears where the plane intersects with the cube. This is a minor situation for most of the people. It will not be noticeable at long distance so it is fine for rendering arch-vis, animation and so on. However, it causes big problem for me.
I usually do close shot for production rendering so this kind of black lines does appear obvious for me.
You may say that make objects not intersect with each other will fix.
That is true, but I have other rendering requirements. I sometimes making in-game assets and render a preview from renderer. The asset could be trees, houses, and even some decal objects. So there are probably too many objects using alpha mask for me to check the intersection and fix every one of them. I just hope Cycles can have a slider to make the blackline thinner to make it more invisible for close shots or Cycles can totally ignore the fully transparent region like Eevee does.

Was able to reproduce this issue with very close view.

Have you reported a bug?
I rendered vegetation in close-up and never had a problem …

I think this becomes a problem with the intersection of transparent with opaque objects, if transparent with transparent, then the issue become invisible.

Thanks for confirming that.
I haven’t report as a bug yet. I am not sure if it is a bug since it is related to something like precision or depth test or some kind like that.
And I think your vegetation render somehow avoided this bug. After some test, I found that the width of the black line heavily depends on the angle between the transparent object and other object it intersects with. The smaller the angle in between, the wider the black line will appear. It two objects are perpendicular, the black lines are unnoticeable.
But it could be a bug and I just cannot verify it with my knowledge.

It may be true, or a known limitation issue.
But anyway report a bug and add link in this thread, I want to subscribe too.

I have reported hope it gets some response from the devs
here is the link:

1 Like

Try switching of cast shadow options on your lights and render again.