Import/export in Blender 2.8

I noticed that meanwhile export/import to/from various 3d formats are activated in newest 2.8 builds.
I tried stl export (which is common for 3D printing) and found out that it’s not working yet.

Is import/expot (at least for most common formats) planned to be part of beta version ?

The importers/exporters that are activated now should work and will be in the beta. If any of the activated ones do not work you can report bugs. The STL exporter seems to be working in a simple test here.

I just compiled 2.8 from sources and exported the default cube as stl. There is a file coming out, but it’s corrupt.
I tried to import to paint3D and cura which was rejected from both programs

By the way there’s an error message in Blender when exporting stl.

Switching to fully guarded memory allocator.
Blender 2.80 (sub 30)
Build: 06.11.2018 11:52 Windows
argv[0] = .\blender.exe
argv[1] = -d
read file C:\Users\peter\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
Version 280 sub 30 date 2018-11-06 10:10 hash 5ccd60e0e7c
Read prefs: C:\Users\peter\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
read file C:\Users\peter\AppData\Roaming\Blender Foundation\Blender\2.80\config\startup.blend
Version 280 sub 24 date 2018-10-02 07:09 hash c14949e9ed1
found bundled python: E:\DATA\PROG\blender-2.8-git\build_windows_Release_x64_vc15_Release\bin\Release\2.80\python
Traceback (most recent call last):
File “E:\DATA\PROG\blender-2.8-git\build_windows_Release_x64_vc15_Release\bin\Release\2.80\scripts\addons\io_mesh_stl\”, line 85, in faces_from_mesh
mesh = ob.to_mesh(bpy.context.depsgraph, use_mesh_modifiers)
RuntimeError: Error: Object does not have geometry data

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “E:\DATA\PROG\blender-2.8-git\build_windows_Release_x64_vc15_Release\bin\Release\2.80\scripts\addons\io_mesh_stl\”, line 87, in faces_from_mesh
raise StopIteration

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File “E:\DATA\PROG\blender-2.8-git\build_windows_Release_x64_vc15_Release\bin\Release\2.80\scripts\addons\”, line 237, in execute
stl_utils.write_stl(faces=faces, **keywords)
File “E:\DATA\PROG\blender-2.8-git\build_windows_Release_x64_vc15_Release\bin\Release\2.80\scripts\addons\io_mesh_stl\”, line 225, in write_stl
(_ascii_write if ascii else _binary_write)(filepath, faces)
File “E:\DATA\PROG\blender-2.8-git\build_windows_Release_x64_vc15_Release\bin\Release\2.80\scripts\addons\io_mesh_stl\”, line 180, in _binary_write
for face in faces:
RuntimeError: generator raised StopIteration

You can report a bug with an example .blend that gives this error:

1 Like

Do you think I really should ignore this instruction " For Blender 2.8, please only report crashes"
Don’t want to bother you developers :slight_smile: .

Two more observations:

  • all other exports are sucessfull. only stl fails
  • could reproduce this error on current download version as well
    (in case my own build version is broken)

@brecht I’d like to make a bug report, but I’m still unsure.
Is 2.8 open for bug reports now, or if not, is it an invitation (from you as developer) to report this bug anyway ?

You can report this bug. In a way this script is crashing anyway.

Allright , thank you !

It‘s fixed, one day after I reported it.
You guys are wonderful ! :blush::v:

With my Raspberry Pi4 the last version I’m able to use is Blender 2.79. It had the same problem when I tried to export my model for the first time to STL. After thinking about it, I concluded that the only things without geometry data that could be causing the problem were cameras and all light sources. I removed them before exporting again, and the problem went away.