How to start a Mantaflow simulation with a flat surface of the fluid?

I’ve been trying to do a Mantaflow simulation starting with a flat surface of the fluid, to simulate the fluid at rest. However Mantaflow displaces the fluid surface even if the fluid is not moving. It appears that this is controlled by the Particle Randomness setting in the Fluid section of the Domain. If you set this to zero then you get a flat fluid surface, but then during the simulation you get a square pattern in the fluid due to the regular distribution of the FLIP particles.

It appears the Particle Randomness setting displaces the FLIP particles in all directions, including the vertical direction, and this sets a wave like pattern into the surface even if the fluid is stationary. If this is indeed the case, it would be better if you could select an option to constrain the random starting position of the particles to be in the plane of the fluid.