Hide overlays option gone :(

Hi I just tried the latest build and notice the hide overlay is missing from the Z pie menu, any chance of it returning?, I used that all the time.

See this: https://developer.blender.org/rB4022a16fbef81f5d4f2aaabd0d627d0c0f529561

But yes, even though those options have a direct hotkey now, it would be better to still have them in the pie menu. I don’t understand why it was removed, it kills the discoverability.

oh sweet, yeah I would preferred to have the pie menu way back, I’m heavily Dependant on them.

1 Like

Also another issue with the keybinding is that AMD uses ALT+Z for it’s Radeon Overlay also, another why I prefer Pie Menu’s over keybindings.

Yes, this is an issue.
but shortcuts like Shift + Z is faster then pie-menu (at least for me)

it’s back now with the option to have the previous pie menu or the 4 directions one…i don’t think this is an issue because u can always modifiy the input or the script to make it work for you, the problem now is the x-ray and occluded option; i think one should stay in Alt+Z(occluded for edit mode) and the other in the pie menu(object mode) depending on their usiblity.

I just checked the new features and I love this choice.

at workflow level it is really very practical and immediate.

just the time to memorize the new type of use of the shortcurt and smooth row that is a beauty.

Options are always good:

Not a fan of pie menus in general tho… :wink:

2 Likes

lol there is also “select all” toggle hehehe!
I just turned it on … and I realized that I missed it a lot …
it’s like I’m back to breathing … very strange :joy:
yes yes yes …

1 Like

I won’t miss that one… :stuck_out_tongue:

at the end “alt + a” continues to work … and I’ll remember to use it in case there is a lot of geometry and I’m going to deselect everything

2 Likes

Pie menu is weak point of workflow.
Especially, in shading modes, if it is needed to quit render via ZZ.

2.79 has wise solution
Z - wireframe (used 80% of times)
alt+Z - texture (8%)
Shift + Z - render (8%)
alt+shit+Z - material (4%)

other options are so much rare, that manual switch is pretty much suitable
So any kind of pie menu being just optional is nice choice.

2 Likes

Even the “extra shading pie menu items” checkbox doesn’t show the overlays option anymore. After all this time, is there a way to enable them on the Z pie menu? I know some people don’t use them, but I’m sure I’m not the only one who misses that feature. It was quite comfortable

What build of Blender are you using. I’m running the release version of 2.81 and I still have ‘Toggle Overlays’ as an option on the z pie menu when “extra shading pie menu items” is on.

You are absolutely right. I don’t know why, but when I toggled it, it didn’t work. I even restarted Blender and nothing. But today it appeared. Not sure what happened but I’m glad it worked. I honestly thought they had removed it. Thanks for the help! I’m using 2.81 as well.

1 Like