Help building Blender on Windows 11, vc17, main branch

For some reason, Python 3.11 was installed to my lib folder instead of 3.10. Since i couldn’t figure out why, i just changed the expected PYTHON_INCLUDE_DIR to 311. Build.log.txt (52.4 KB)
CMakeCache.txt (150.8 KB)

what is the output of make showhash in the source folder?


9da88301efea47d184f347f2b2e54742351361d7 is main from 5 months ago, you’re building against current libraries.

Yeah, i couldn’t figure out how to sync my fork.

Unless you are working on the code, checking out the main repo is the easiest way. Just run make update then to update and check the docs if something is unclear. Windows - Blender Developer Documentation

I did have some edits, but i wanted to build and test that branch to make sure they work, before making a pull request. Then i think i had trouble building that branch, so i lost interest in it for a few months, and focused on other projects. Should i just start over with a new fork, or can i sync this one to the central Blender project?

  • Commit all your changes to your fork.
  • check out the main branch
  • run ‘make update’
  • check out your fork
  • run ‘git merge main’ , this brings the changes in main into your branch. If stuff was changed in main that you also change you’ll get conflicts which you’ll need to solve.

Now you should be up to date and able to compile againste the current libs.

@LazyDodo pointed out to me that this isn’t going to help because you only have a checkout of your own fork. So you’d need to first add blender’s main repository as a remote and fetch main from that.

I’m new to using git outside of github. I just tried using the CLI to add the remote a couple of times, but i don’t think i understand how to use the commands for it. From my main branch i did git remote add -m main master [email protected]:blender/blender.git, then to make sure it worked, i did git remote show master and got Permission denied (publickey). Am i doing this right?

You should do:

git remote add origin

This will create a remote called origin containing all it’s branches. As I don’t think you have write access to the main blender repository I used the read-only https:// version.

Then do git fetch origin to get all the branches into your local storage.

then git checkout main to switch to the main branch.
then git merge --ff-only origin/main to get origin’s changes into your local main branch.

and then you can finally do

git checkout yourbranch
git merge main

Ok, now when i tried to merge, i got merge: origin/main - not something we can merge with no further clarification.

Could you post the output of git remote -v?

Maybe it’s easier/quicker to resolve this via the chat on Blender Chat

origin (fetch)
origin (push)

Hm, that looks ok.

and the output of git fetch origin ?

remote: Enumerating objects: 87667, done.
remote: Counting objects: 100% (87667/87667), done.
remote: Compressing objects: 100% (11304/11304), done.
remote: Total 130064 (delta 84329), reused 76792 (delta 76363), pack-reused 42397Receiving objects: 100% (130064/130064), 114.23 MiB | 3.82 MiB/s
Receiving objects: 100% (130064/130064), 115.91 MiB | 2.10 MiB/s, done.
Resolving deltas: 100% (108613/108613), completed with 13825 local objects.
 * [new branch]              anim/animation-id-113594 -> origin/anim/animation-id-113594
 * [new branch]              asset-browser-frontend-split -> origin/asset-browser-frontend-split
 * [new branch]              asset-shelf             -> origin/asset-shelf
 * [new branch]              bevelv2                 -> origin/bevelv2
 * [new branch]              blender-projects-basics -> origin/blender-projects-basics
 * [new branch]              blender-v2.93-release   -> origin/blender-v2.93-release
 * [new branch]              blender-v3.3-release    -> origin/blender-v3.3-release
 * [new branch]              blender-v3.5-release    -> origin/blender-v3.5-release
 * [new branch]              blender-v3.6-release    -> origin/blender-v3.6-release
 * [new branch]              blender-v4.0-release    -> origin/blender-v4.0-release
 * [new branch]              blender-v4.1-release    -> origin/blender-v4.1-release
 * [new branch]              bridge-curves           -> origin/bridge-curves
 * [new branch]              brush-assets-project    -> origin/brush-assets-project
 * [new branch]              gpencil-next            -> origin/gpencil-next
 * [new branch]              main                    -> origin/main
 * [new branch]              realtime-clock          -> origin/realtime-clock
 * [new branch]              sculpt-blender          -> origin/sculpt-blender
 * [new branch]              sculpt-dev              -> origin/sculpt-dev
 * [new branch]              temp-sculpt-dyntopo     -> origin/temp-sculpt-dyntopo
 * [new branch]              tmp-usd-3.6             -> origin/tmp-usd-3.6
 * [new branch]              tmp-usd-python-mtl      -> origin/tmp-usd-python-mtl
 * [new branch]              universal-scene-description -> origin/universal-scene-description
 * [new branch]              xr-dev                  -> origin/xr-dev
 * [new tag]                 v3.3.11                 -> v3.3.11
 * [new tag]                 v3.3.12                 -> v3.3.12
 * [new tag]                 v3.3.14                 -> v3.3.14
 * [new tag]                 v3.6.3                  -> v3.6.3
 * [new tag]                 v3.6.4                  -> v3.6.4
 * [new tag]                 v3.6.5                  -> v3.6.5
 * [new tag]                 v3.6.7                  -> v3.6.7
 * [new tag]                 v3.6.8                  -> v3.6.8
 * [new tag]                 v4.0.0                  -> v4.0.0
 * [new tag]                 v4.0.1                  -> v4.0.1
 * [new tag]                 v4.0.2                  -> v4.0.2

Could you try git merge origin/main again? It looks like your last git fetch origin command actually only now downloaded everything, so maybe you forgot to do that the last time?

Ok, i did that, and after fiddling with it a bit more, i think I’ve almost got it. Blender fully compiles, but won’t run because “it’s side-by-side configuration was incorrect”. The error message says to check the event log, but i don’t know where to find it.

build the INSTALL project, should be tucked away in one of the top level folders of the solution explorer.

Nevermind, i woke up today and opened the project to find 10 errors that weren’t a problem yesterday. I changed nothing, so i don’t know where they came from. Is there another log file, or cli command i should share that can help understand what’s wrong?

“I have errors” with no further information is hard to help with, you’re gonna have to be a bit more specific.

With nothing to go on, best advise i can give is probably running git status in the blender source folder to validate your assumption that nothing was changed.