Hair mesh scaling not great

This might be off topic but i now stumpled into the problem and read years ago that its because the hair particles are using world space and not object scale. The problem is that you cant scale a mesh with hair without messing it up.

I could not find a solution for that because adding a driver to the length is not possible (its greyed out)

It would be great to have a solution without a redo of the hair…

1 Like

I actually managed to fix it. For everyone having the same problem:

  1. Scale down the mesh with the hair (hair will look messy)
  2. Disconnect every hair system from the mesh to apply the scale on the mesh.
    -reconnect (the hair will be too thick but adjust laster in the hair settings)
  3. Play again with the settings of the hair system ( In hair Shape: Radius Root and tip and clumping when you need.)

In conclusion the scale of the hair is a problem because its not connected to other settings in the hair simulation that has to be adjusted.

1 Like