GLTF (export add-on) auto smooth option problem

GLTF doesn’t export normals of a mesh when the auto smooth option is checked in the properties Editor’s object data tab.

try it yourself:

  1. shade smooth a mesh object in object mode
  2. go to properties editor > Object data properties > Normals > (check the auto smooth option and adjust the angle to your liking)
  3. export as gltf/glb
  4. import it back into blender or a game engine and you’ll see that the normal will only be shade smooth(e.i it wouldn’t right the custom normal if it is shade smooth/sharp)

this option works for obj, fbx, Dae etc except for gltf

thanks #blender #b3d #developers #dev

For bug reports, please use the bug tracker:

1 Like