Font detection... a deal breaker

I have STRUGGLED to get blender to recognize .TTF in my default fonts folder and blender only shows BASIC fonts, but NONE of the other fonts that are downloaded into this folder. While blender may be a cool free open source platform, THIS inability to detect fonts that ALL OTHER software can detect is right on the edge of being a DEFINITE deal breaker for me. I am not going to spend that much time wrangling with something that should be FULLY functional! If my client is looking to have something delivered in a reasonable ab=mount of time, I should be able to deliver. I cannot spend MORE time on a SIMPLE project and charge MORE… customers look for the best deal available and the best delivery time. Unfortunately, this one feature fails to allow that to happen. I will try to find a solution for this, but I feel that I will be uninstalling this headache for a much more FUNCTIONAL software.

Do you mind explaining better what you have tried, what you mean by “recognize”, what operating system you have, etc. Maybe include screenshots if you can.

Blender does recognize and work with “.TTF”, “.TTC”, “.OTF”, “.OTC” files. Even old “Type 1” fonts (".PFA"). It also works with “.WOFF” too although that isn’t included in our default filtering.

1 Like

Well i had a problem too.

In the windows font folder the font is there but not in blender. Not sure why but the solution is to navigate to the downloaded font file and use it.

Its not where it should be and i searched with find and normally but could not find it.

Mine is an otf file.

In the Windows operating system you are given a choice when you install fonts. You can do so for just yourself or for all users. If you select “all users” it will be copied into your C:\Windows\fonts folder. If you choose to install it just for you then it will go to C:\Users(username)\AppData\Local\Microsoft\Windows\Fonts

When you browse your C:\windows\fonts folder outside of blender the OS kindly and automagically combines these two folders together. But Blender just lists the folder contents and shows you what is actually in the folder.

A fairly simple workaround is to just browse once to your C:\Users\(username)\AppData\Local\Microsoft\Windows\Fonts\ folder and bookmark it so you have quick one-click access to it in the list on the left side of the File Browser.

I do have a patch that makes Blender do the same thing as the OS, combining both folders together, if you build blender and can therefore test it and offer some feedback: ⚙ D13293 Fix T61398: Show User Fonts with System (Win32)

But if you can’t compile blender yourself you can still try it. There is now a custom build of blender that incorporates this change that you can download from here: D13293 (Combined System & User Fonts) Builds

3 Likes

Thanks for the quick help. Win11 seems not to ask where i want to install the font that’s a pity.

Great that there is already a build. I currently have not setup building blender.
I tested it and it works, so that patch seem to be a nice addition for master. Nice work!

Thanks! I’ll see if I can turn it into something. I like the functionality of it, but am not happy with the implementation yet.

1 Like

When you right-click on a font, even in Windows 11, you should see an option to “Install” or “Install for All Users”. The first option put it in C:\Users\(username)\AppData\Local\Microsoft\Windows\Fonts\, the second option puts it in C:\Windows\fonts

But again, just bookmark that user fonts folder and you’ll have access to everything.

1 Like