Error building, At least Python 3.10 is required to build

hi, im not a developer i had being building blender in ubuntu following the steps in the wiki Building Blender/Linux/Ubuntu - Blender Developer Wiki it was working great so far but today i try to compile, its being a few days since the last time, and i have this error


I was aware that blender was moving on with python version, but i didn’t expect this error, i now realized that i have to update something but im not sure what. .
after going around and googling i found out that apt get has some python libs (i had to google that, im not a developer nor a linux geek) but there is no python 3.10 in the list

¿could someone provide a clue about how to fix it or at least where should i start looking?
im really lost here, my environment are the vertex and the edges.
Thanks

easiest is to just use our library set in SVN, if follow our build guide this is the default method we offer.

so if i just re run this it should replace and add the new pithon?

if you already have them, you can just run make update in the source folder and it’ll update them

i think i have all the process right, it was building properly a until a few days ago, it seems that the library its there

we occasionally update them, it’s recommended to run make update on a regular basis, if it keeps giving you trouble just remove your build folder and it’ll sort it self out.

1 Like

ok ill try updating tomorrow or redo the process is still nor working.
thanks

I am getting the same error with python 3.8 and blender 2.93

CMake Error at CMakeLists.txt:911 (message):
  At least Python 3.10 is required to build, but found Python 3.8

In my case, I am building blender as a module to use in a python3.8 library (I need to be able to compile for different minors of python 3).

I ran the following build command

make bpy BUILD_CMAKE_ARGS="-D PYTHON_VERSION=3.8"

Do I need to compile the dependencies manually in this case?

Couple of things, blender 2.93 shipped with python 3.9, so it asking for 3.10 seems “iffy” are you sure you are building the code you think you are building? The 2.93 tree has the version check on line 839 and checks for 3.9.

As for the version check, usually when we add a check for a minimum version, we use parts of the API that the new python version offers, so it’s quite likely the code really just won’t build against older python versions.