Eevee SSS doesn't seem to work


for some kind of reason I can’t seem to get SSS to work in Eevee, whether it is from the Principled BSDF or the SSS Node. Ticking the SSS Box in the Render Panel doesn’t affect it at all, nor does switching from Christensen to Random Walk Mode. Anyone else experiencing this problem.
Updating to the latest 2.8 version hasn’t helped either.

If this is the wrong place to ask, feel free to tell me!

Win 10
GTX 1060 6G
Intel Core i7 7700HQ

Did you also it in the materials options itself?

1 Like

Aside from enabling the SSS option in the Render Panel, You have to enable it Also in the Material options in the material itself.

Hope that helps.


My apologies for something so obvious. Thanks! It helped

Maybe it is a good example that SSS option needs a warning about to activate SSS in each material-> options.

Because in other engines if you activate SSS in render options and you put a material with 1 of SSS you obviusly need to see the SSS effect.

1 Like

Indeed, for now you have three Options that have to be checked: (SSS in Render Panel, SSS in Materials Panel and the SSS Value). It would be logical to only have two: One for generall SSS to improve Viewport rendering when not checked and one in the Shader because it is obvious for me if you put a value other than 0 in SSS Scale, that you want SSS to be enabled on that Material.

SS Translucency might be alright there…


Yeah, I agree it’s a little hidden as it is.
I understand maybe it’s a way to make things more efficient and not calculate SSS for EVERY material once the option is active in the Render Options ( even for the ones that have a 0 value for subsurface ).
But maybe automatically enabling that Screen Space Subsurface Scattering checkbox for materials that have a sss value higher than 0, when eevee is selected as the renderer.
Or maybe as you guys said, a warning at least would be convenient, something similar to when you apply a lattice modifier to something but haven’t picked the lattice that is to affect the geometry.


Good Idea in generall to highlight things that don’t affect yet your scene or will be affecting once you check certain boxes

It seams like the Screen Space Subsurface Scattering option in the material settings is redundant to an extent. There may be times when you want to turn it off to optimize 3d View performance, but I think for the most part if you set SSS to something other than zero in the material, this option should turn on.

I’ve been wondering why SSS in Eevee hasn’t been working for months, and now i find it’s because of this hidden away option! lol. That option under Material settings shouldn’t need to be checked.