Eevee light set to 0

It’s more of a feature request than a bug I guess, so I’ll put it here. In Eevee rendered mode when light has “shadow” turned on it will slow down viewport even if it has Power set to 0. So even if it’s not contributing anything to the scene it will kill the performance.

1 Like

Also when you hide it or something? could have a special collection with your turned off lights…

No, hiding light works as expected. It’s not a big problem, probably not worth dealing with.

This is a good request. Since you may want to animate the light power and don’t want the overhead if light power is 0.

1 Like