Edit: Blender 2.8 threading problem (Cycles) for sure (Videos added!)


There are threading Problems in Blender 2.8, when using CPU + GPU

This video shows an example rendering without the treading problem. It takes a little over 3 minutes.


This is an example with the threading problem. The calculation of nearly the same scene (only the main characters moved a very little bit) and with exactly the same Blender 2.8 settings it takes over 5 minutes. The GPU usage goes up to nearly 100% and the GPU is not faster then the CPU cores anymore


I had the computer running over night. As i looked at it next morning it was with the threading problem. I just closed Blender, started it again, load exactly the same project, start it and it was much faster again.

I filmed it with my smartphone camera, because when the threading problem occurs and I try to make a video with windows apps, the problem disappear when I start the recording. This is an additional hint that it is a threading problem.

PLEASE do something about it !!!

If you need any information e.g. about used options … just ask I will help as much as possible!

Updated, please help fixing the problem! (look at first post)

If you think you found a bug, please report it in the bug tracker, providing all the requested information:

This forum is not meant for support or bug reports. You might also ask on user forums if others have had similar problems and possible solutions they found.

Thank you. I posted it there:

First Result: The Problem seems to be connected to the Windows Blender GUI. It disappears when using the Command line Option for Blender meaning to start the Rendering with:

blender -b “Path to *.blend file” -a

without the “”