Cycles X Viewport slower with both GPUs enabled

When I enable both of my 3090s, my viewport slows down substantially. However, my final renders take about half as much time.

Disabling my second card makes the viewport much faster, and the renders - obviously - slower.

Is this because I’m not using an NvLink bridge? Are there any workarounds so I don’t have to keep changing my settings?

report this in the feedback thread, until a proper bugtracker is alive…

The slower viewport with duel GPUs is related to background light bleeding?

I really have no idea :wink: