Cycles issue with volume lights (not really excluding lights from volume samples calculation)

Hi. sorry if this issue has already been flagged but I haven’t found this mentioned anywhere.

Basically what I noticed is that cycles when using volume lights, if we exclude lights from the volume contribution it still affects the sampling of the visible volume lights.
Ill illustrate the issue bellow:

On the image above we see just 1 spot light on the scene casting volume with default settings and in the square we can observe a decent sampling near the light origin

On this image we have several duplicates that results in obvious degradation due to the lack of volume samples (I’m always using the same amount of sampling on this test)

On this 3rd image the volume scatter contribution of the duplicates was turned off, but we can still observe the sample degradation on the only visible volume light as if the other lights were still visible in volume scattering.

From this I can conclude that even though the volume scatter contribution of the lights is turned off, they still affect the volume sampling calculation, which means that there is room for optimisation.

Not sure if this a trivial issue to be solved in the code, but we could expect a quite considerable gain in quality and speed when doing big lighting scenes where some lights can be used in the scene with volume off and some with volume on without having to do separate volume passes.

Seems like the MIS for this kind of light is not being weighted by the total light energy output, which is probably a reasonably useful heuristic for it’s importance. Should be a relatively easy fix, worth writing up a bug report for it.

Reported, thanks for the support.