Cycles detecting two of a single graphics processor

Hi all:

I created a benchmarking script around Blender, and I noticed something strange with certain graphics cards. The issue is easily seen here:


I’ve never encountered an issue with CUDA detecting more than one graphics processor, but for some reason, certain AMD Radeon GPUs do. As seen in this image, one Radeon VII shows up as a single device no problem, but the one Radeon RX Vega 56 shows up as two separate devices. That being the case, this isn’t related to AMD’s Vega architecture in particular. The Polaris-based WX 5100 shows up the same way, with the double listing.

In this configuration, if all three devices are selected, I get an out of memory error. It works fine if the first Radeon is selected, and the second is left out. If I try to render only to the middle Radeon device, it again errors. This device is showing up, but it has no relevance at all.

That all said, if I take the userpref.blend file from the configuration that shows two graphics processors, but only have the first one selected along with the CPU, that same userpref.blend plugged into another Radeon rig will properly select only the GPU and CPU if the middle device is “missing”.

Does anyone know what might cause a GPU to show up twice? I install all GPUs the exact same way; it’s very specific models that end up doing this (and I have not cataloged them all yet; I am finishing testing NVIDIA GPUs first since those haven’t given me this issue.)


Ỳou can try checking the output of clinfo in the terminal, to see if there are multiple graphics cards detected there, or perhaps multiple OpenCL implementations. Further, you can run Blender from the command line with --debug-cycles to get more details on how it is detecting these GPUs.

1 Like

Thanks for the info! I did not expect such a quick response :smiley:

I made a decision to deal with this AMD stuff after I get a few more NVIDIA cards tested, so I can deal with the collection (and this issue) all at once. I’ll get one of the suspicious cards installed later and test this out!

I’m also getting this issue with my Asus Vega RX 64 on Windows 10, and doing what Deathspawner said, fixed it for me.

The same render that took me 8 minutes approx on my CPU only (Intel 4670k), now took me 1 minute only (on combined, where second GPU listing was disabled). Though I’m still not sure, if the issue is fixed. As during render, my GPU load in task manager was around 5%