Custom Normal Editing

Definitely not working for me, you sure this is default behaviour not add-on?
I don’t ever recall seeing rotate tooltips saying “press N to affect normals instead” or anything along those lines.

That’s quite strange. It should work with no extra add-ons. To be safe, I just tried it on another computer that’s never had Blender on it and it worked.

1 Like

Video doesn’t play back for me (and when I try to open the site it warns me of troijan…)

But I did get it working by downloading latest 2.8 build. (Seems to be fairly new addition? Do you have the patch/commit link from dev webpage so that I could check it out)

To modify normals You have to enable autosmooth option

BTW have anyone figured out how to modify one of merged vertex’s normals without splitting and merging?

1 Like

Ahh thank you…

My issue was that I had a subsurf modifier on, which negates the custom normals…

also autosmooth should be ON by default and set to 180° instead of 30°, it took me a while to figure out why shading in blender is not similar to other apps by default and having to do it manually for each object is very slow and frustrating …i think we need a better and intuitive solution to smooth shading and normal editing…if any dev can chip in on this matter!!

It probably shouldn’t, though.
Anyone who knows of the feature is capable of going to the menu and turning it on at whatever angle they need.
If autosmooth was turned on by default it would cause confusion for people who don’t know about it wondering why exactly every transition above certain threshold comes out as sharp while sharper angles don’t.
Maybe the whole auto smooth menu options could be duplicated under the Smooth/Flat settings in Tools panel (albeit I’m not sure whether that makes sense in 2.8, probably not)

Reread what was said:

What you mentioned wouldn’t be an issue at all.

1 Like

the current setup doesn’t behaive as expected , actually with autosmooth off it confuses more because for example if you smooth shade and make some edges sharp from the menu won’t see them sharp unless autosmooth is enabled with 180° which doesn’t affect any transition, and then if you want to change the angle you get the option, hwoever having this as a global option that can also be applied to multiple objects at once is also ideal.


This was talked about with devs sometimes… And I don’t remember, but I think that was discarted by some reasons, maybe perfomance.

Maybe the best would be change the name of autosmooth to “advanced normals” or something similar, because it activate custom normals, and change the angle value to “autosmooth angle”.

Also have some warning about custom split normals data, that change the normals behaviour of imported FBX, for example.

1 Like

Can we have calling auto smooth op from mesh>normal menu set at first row? That would make sense as without turning it on all options are disabled?
Also this:

i asked Pablo on the stream, and actually it was there in the beginning but not obvious to end users…you have to hold ‘alt’ to apply to multiple objects at the same time, maybe just a remark on the tooltip that it exists will do the job :slight_smile:

1 Like

The Alt-modifier to apply to selected is a general feature, not a feature of Auto Smooth. We should change this in a generic way.

Here’s a design task for how we think we will solve it:

1 Like

“Multi object properties editing” that’s even awesome than i expected ,thanks.

Hi all, I am late to the party, but is this an oversight to the current design? How can we edit individual normal of a split vertex?

My problem is very specific in that:

  • I rely on Data Transfer and Auto Smooth to set custom normal.
  • But I also need to the edit said normal data as split vertex.

As it stand today, I can have one or another, but not both?

With Auto Smooth on: we got custom normal, but can’t edit split normal individually.
With Auto Smooth off: we don’t have custom normal, so can’t use Data Transfer.

(EDIT: to be precise, what Zuorion said does work, I can separate that face and then align normal to face, then join them back; since they are split already, existing normal won’t change.)

(EDIT2: the best solution so far appears to be, (1) set hard edges + auto smooth, (2) apply data transfer to copy normal, (3) apply edge split to get split vertex and normals (4) set vertex normal to face normal.)

To edit an individual normal of a split normal vertex, follow the instructions in the 2.8 release notes.
Copying the relevant section:

To select a custom normal associated with a particular vertex and face:

  • Make the element selection mode both Vertex and Face (use shift-click to enable the second one).
  • First select one or more vertices, then select a face. This can be repeated to select more vertices and a different face. And so on.

Is it just me or the ^ doesn’t affect the visuals in Cycles nor Eevee at all? I have vertex normals pointing inside the mesh but the shading still looks perfectly normal.

Also when using the operator “point normals to object” if you use the pie menu to go to “edit mode” this consistently crashes blender. (If you use it while being inside the modal phase of the operator. For lot of other things like extrude or inset you can’t call the pie menu during the modal phase so might be isolated to the normal tools)