Cryptomatte Metadata Missing in 2.8

We’re using Nuke here, but don’t use to have scenes with such a high object count, we typically don’t exceed 3.000. Do the Cryptomattes you have generated work within the Blender Compositor?

Yes in the Blender compositor cryptomattes work normal. If I wish I can output b/w mask but thats so slow. For us the blender compositor is no option and nuke too expensive :slight_smile: .
We import all the cad-parts of cars. Unless we are beneath 22million polygons everything works fine in blender.

Hi guys. There’s no metadata in exr file regarding cryptomatte or and official dneg cryptomatte gizmo for Nuke can’t extract any matte from it.
example 1 file in 2.79 and 2.8

how I can fix it?

1 Like

it looks like no one has an answer to that.

The file was closed with this comment

I think it would be much nicer if the file just worked. The solution would be to include the same MetaData in exr file if at least one cryptomatte channel is connected to file output node in Blender, but that is a Blenders problem.

@brecht just to confirm this, in your tests, have you tested the file output node from compositing?

In those links one thing mentioned is that the needed metadata is not present when using the compositor, but it works with the default output.

The Blender compositor indeed does not preserve metadata with the file output node, that’s a limitation currently, there is no type of metadata node socket for passing along that information from one node to another.

Can the metadata be added to any OpenEXR and MultiLayer OpenEXR file output nodes present in the Compositor regardless of what is connected to it? I assume the added file size is neglectable. Would be SO useful to have it.

1 Like

Yep, a good idea would be to have a “copy metadata from output” checkbox in the output node that will blindly copy the metadata of the original output no matter what as long as the output node is configured as Multilayer EXR


sorry 4 my English if any situation)
In finish we have:

  1. Out files with compositor is dont work. But it will correct work if we make out in scene-output. I just need ON crypto in passes and set settings out multiOpenEXR? Thats all, I can rendering sequence?
  2. I find fix. Totally cant understand, what need to di with it…
  3. Using 2/79 latest. Dint understand too, how…
  4. Compositor in 281 isnt working in all ways.
    May someone explain one working way step by step?
1 Like

To be able to use that fix you would need to build your own version of Blender and apply this patch.
I can apply it to our build and you will be able to use it, but since it’s the build we use for work I have to confirm just one thing:

@brecht if I apply this patch to our build, would it break backwards compatibility in some way or it’s not too problematic?

Are you sure this is a patch at all? To me this looks like a normal commit which is already in master, unless I am mistaken? I believe this fixed a bug where Cryptomattes where missing altogether in the render output, I can’t see where this code checks for file output nodes.

@joe_vfx, I tried to rename the metadata as suggested. Doesn’t work. Mine says View Layer.CryptoObject (with a space between View and Layer, which is strange) instead of RenderLayer.CryptoObject. I tried with and without a space. I tried to use RenderLayer instead of View Layer. Nothing.!


I updated the cryptomatte plugins to the latest version (2020!) and it still doesn’t work even though it was supposed to fix the Blender cryptomatte issue.

Any suggestions?

1 Like


Which settings do you have in blender? Can you send me a screenshot of them (especially the layernames). With the new version of the cryptomatte plugin in Nuke it should work even without the Metadata node…

So I think that there is something wrong with you Layer names in Blender.

Here are the settings. I didn’t use any layers. Just default stuff.

Can you please re-download the plug-in from PsyOp? They merged a fix I provided yesterday. Then try again in Nuke if that fixes it. If not, please consider to provide a simple blend file for testing the problem.


Have you tried renaming “View Layer” to something different? (Without a space in the name)

Whooho! We have a winner! I updated to the latest version of Cryptomatte and it’s working. I also tried with a space in the layer name but it made no difference. Nuke adds the “_” automatically. Now I only need two more things to make me switch completely form Maya to Blender: Proper UDIMs and support for VDB caches. The more I use Blender the more I like it. Thank you all for the help!


sorry, U updated what?