Color picker should pick real color instead of mixing it with a texture's alpha

sample black

As you can see, trying to sample a color from a transparent texture, at a spot where the color isn’t 100% opaque, results in the color picker choosing a color that is too dark to be used.
Same happens when trying to pick the color on a character (imagehosted here: sample-black2 — ImgBB)

In this case I am using an alpha texture with a multiplication node ontop of a base skin texture, to add details such as the skin darkening here. As you can see, Blender’s picker doesn’t realize this: wherever the alpha texture ends, it picks up pitch black – not nothing, not the color of the multiplication layer, not the color resulting from the combination of the two layers, which, because of the multiplication node, is a lot different. It would be an extremely practical feature to enable picker settings like “pick globally/pick active layer only”, and not let alpha affect the value when picking from a semi-transparent color, as in the first gif.

3 Likes

It’s picking what’s displayed on the screen. That’s how eyedropper tools normally work.