Collections 2.80

Short Version: Collections seem unfinished. Any updates on the progress of them?

Long Version:

I’ve noticed that collections have been missing from the alphas for a while now just dangling at the bottom of the properties panel with nothing in it. It’s nice to see it back for the beta release, but I opened up the beta and the first thing I did was duplicate the obligatory cube twice, then selected them all, and did a CTRL+G. I typed in Test for my collection name. The Scene Collections remained unchanged in the outliner. I selected two of the cubes and CTRL+G’ed again. No change. I looked at the cube properties (specifically collections it was participating in) and found that is was indeed included in both Test and Test.001. Yet neither show up in the outliner. This seems like an unfinished feature rather than a ‘bug’ to be fixed. Or maybe it’s just a really big bug! :slight_smile: Here’s a screen shot of the offender:

As you can see, no Test is included, while you can see that Cube is selected and hiding underneath the list of Collections is the assigned collection to the currently selected object “Test”.


The G-key operator are unfinished. For now it’s best to use M-key to move to and create collections in the scene.

Ctrl+G actually works practically the same as 2.7, in that groups also were not part of the scene hierarchy. But this is confusing and will be improved.

1 Like

I see you’re one of the first users on here… would you happen to know why my badges aren’t showing up on devtalk? Seem fine on cloud and blender id sites.


It seems they just showed up, not sure who fixed it or if it was automatic :slight_smile:

Any new improvements regarding this? I get the same result as titalus when adding objects to collection in the object tab. Does add to collection in the object tab do the same thing as ctrl+g?


As @brecht said, for the time being is better if you use the M hotkey to create a new collection or to move inside a collection (or use the outliner)